Podium DD2 not powering up my wheel rims

Hi

Has anyone had an issue with the base not powering the rims, is as if there is no power going to the rim, no LEDS now screen cant assess menu or even use buttons?

Any help is appreciated!

Comments

  • Benjamin KusBenjamin Kus Member
    edited November 2019

    Make sure the Kill Switch is not pressed in, or even unplug it to check it is not related to the kill switch. I made that mistake when I first installed mine, thinking my DD2 was DOA!

  • I have the same issue with my DD1 as of yesteday. It powers up and seems to work fine but none of my rims will function when attached to it and the rims do not show up on the Fanalab software or the Fanatec contoller profile.

  • Hi John

    I just read about your issue with the DD1 that none of your rims are working. I have the Fanatec Podium Racing Wheel F1 version of the DD1. Yesterday I upgraded the driver to v353 which is part of the P BME Software Package v.1.1, to get ready for my Podium Steering Wheel Porsche 911 GT3 R Suede. https://fanatec.com/eu-en/steering-wheels/podium-steering-wheel-porsche-911-gt3-r-suede. I then updated the base firmware, the motor firmware and the wheel firmware on the formula rim (I dont have the porsche wheel yet). I could play in GT Sport for an hour and then suddenly the wheelrim just lost the connection to the base. When I turn on the base, the wheel formula rim is not recognized and nothing show in the LED screen on the formula rim. The wheel icon doesn't show on the base, only the pedals icon.

    Can you explain if you updated the driver and firmware as well when yours rims stopped working? Did you find a solution (like boot loader mode and downgrade the firmware)?

  • I don't think my issue was related to a driver or firmware upgrade because I had been on 345 since 9/6/19 and using it daily with no issues until 12/8/19. I did reinstall the driver and firmwares included with 345 but it didn't change anything. Fanatec had me send them a video of the issue, where I showed them the rims not working when installed on the DD1 and working on the CSW. After submitting the video Fanatec had me return the unit for repairs.

Sign In or Register to comment.