Universal Hub FunkySwitch on DD1

Hello,

Has anyone heard of the funkyswitch on the universal hub being programmed incorrectly?

Click Up = D pad right, Click Down = D pad left, etc

You get the point.

Is there a way to reprogram it or is it wired wrongly?

Thanks for your help.

Comments

  • What firmware? Fanatec broke the universal hub 4 months ago with the current beta.

  • Good question. I’ll have a look when I get home.

    I’m going to install v346 I think. I installed the latest beta before I left for work but since read that only a couple of buttons work on the universal hub. So that’s a no go!

  • It’s hard to know what drivers to install, especially when I’ve got a few different wheels. (Also formula V2).

  • Ok so tried about 4 different drivers now and none of them allow all buttons to work on the universal hub.

    Can anyone help please?

    Thanks, Chris

  • edited July 24


    When you have tried the 4 different drivers during the upgrade and downgrades did you uninstalled / deleted all previous drivers every time and also downgraded the correct firmware package that is intended to work with the driver you have chosen?


    What PC driver, Wheelbase firmware and motor firmware you are currently running?

    Depending on your driver might an easy fix from driver choice, then calibration or even UHX to be broken.

  • Thanks for your help but it’s sorted now...I was forgetting to install the firmware for each driver. Stupid I know.

    I do have a FunkySwitch/D pad that seems to be Faulty though. Click up and it goes left etc. Think the rotary switch may be installed wrongly.

  • All sorted...they had screwed the FunkySwitch into its housing rotated around 45 degrees.

    Simple fix 🙂

Sign In or Register to comment.