Pedals V3 random disconnections

edited August 2020 in Pedals


I'm a little bit worried. But let's see if I can sort it out somehow.

Wheel Base: ClubSport V2.5

Pedals: ClubSport V3

Wheel: F12020 ClubSport Limited Edition

Today I have updated the drivers from version V328 to version V365.

Tonight while playing F12020 on PC, I notice that the pedals suddenly stop working. To then resume. And this more and more frequently. As if it constantly disconnects, especially when I brake.

To do some testing, I turned off the wheel base. I disconnected and reattached the pedal cable to the wheel base. I turned on the wheel base.

I did a new session on F12020. After 10 minutes, the problem returned.

I am attaching a video where you can see the Fanatec Wheel Property Page and what happens then in game (in the final part, I have the throttle constantly pressed).

The wheel base is connected via USB cable to a USB-HUB 3.0. But I don't think it's a USB cable problem, 'cause the wheel base and the steering wheel stills work. And Windows doesn't make the classic device removal sound.

How can this be solved? I bought the bundle a month ago.



  • The pedals V3 does the same thing even connected directly with USB.

    I will contact support, I understand.

  • Looks like a problem :-(

    If you disconnect the pedals and use the paddles on the Formula rim do those work consistently?

  • edited August 2020

    I didn't try, honestly.

    I read on the web that it could also be a problem that depends on the vibration of the pedals.

    Note that with the old firmware (V328) I never had a problem. But it's a bit of a "work around" to go back to the older version, right?

  • It might be a work around but I'll take a working work around any day!

    I think the process is fairly easy - uninstall current driver, reboot windows.

    Install new driver - reboot windows

    Launch driver and update/downgrade the firmware for each device that has firmware (2.5 base, 2.5 motor, pedals)

    Also, be sure you don't have the pedals attached both to the 2.5 base and USB at the same time - I've read that's bad.

  • edited August 2020

    I'll try. But I still opened a request for assistance.

    Edit: with the old firmware, happens the same. RIP.

  • Had the same issue with totally new V3 and DD1. Pedals disconnected randomly always with shorter intervalls ... after 2-3 days the didn´t connect anymore, neither with USB nor RJ.

    Requested help from the support - team, but didn´t got an answer till now (and it´s the 5th day ) :-(

  • edited August 2020

    They will tell you to ship the V3 for repair (RMA). I thought I had solved the problem, but then it came back.

    I shipped the V3 on Monday and it arrived at its destination today. They take up to 10 working days, but better to solve the problem well than have the doubt.

  • I solved the problem ... I already ordered Heusinkveld Sprint Pedals and they will arrive tomorrow ;-)

    I think it´s very poor support from Fanatec not to answer within 5 days ... knowing, that the only solution is to send them back for repair. Loosing days and days for nothing ! Think they would react a lot quicker, if I stop the Paypal money transfer ...

  • Got Feedback from support: They told me to reinstall drivers and flash firmware. Wondering how to do that, if pedals aren´t working at all. They are dead ... simply dead.

Sign In or Register to comment.