Problem with DD1 firmware update


I have a problem with my band new DD1.

Downloaded an installed firmware 346 from

Then I started PC set up and a message came up to upgrade to 352.

So I started the firmware updater but then I get the message

"device connected "

"No response from the device. Operation failed"

And if I change plug to another usb port I get the message:

"device connected "

"Default Hex file loading failed"

Before all this tried to play F1 2020 the the steering wasn't working correctly (no linearity in my input movements with the in game output) that's why I started searching what is wrong

Hardware set up:

DD1 Base

Formula V2 Streering wheel

Heusinkveld Sprint pedals

Thank you in advance for your answers


  • I think some of the more experienced guys on the forum have posted ways around this - I don't remember if it was a driver cleanup utility, or an uninstall/reinstall, etc - but it might be worth doing some searching until one of them comments here.

    I also think that for the DD1, the driver on the DD1 page works as does the beta driver 365


    And I do remember reading that before any driver change, you should go into add/remove programs and uninstall the old driver, then reboot windows.

    Ideally I'd love to see one of the more experienced members offer more advice, but if it was me, and I was stuck on a weekend, I'd likely uninstall the diver, reboot, reinstall 346 and try reflashing the wheelbase firmware, then the motor, then the rim. Always test it in the fanatec driver - you can turn the wheel there and hit the buttons and it should reflect on screen.

    Also for your F1 issue, it sounds like what you're describing might be a mismatch between the rotation the game is expecting vs the wheel, so once you get the firmware sorted out hit the setup button on the F1 wheel, use the funkyswitch to find SEN, and change it to something like 360 or 180 and see if that gives you the feel you're looking for in that game. Note that you have 5 profiles on the wheel, so you can choose settings that work great for F1 and put them in profile 1, and then use Profile 2 for another game, etc...

  • Thank you @Jack Fruh !

    Tried following drivers

    (every time I uninstall the previous one then install another drive, then restart PC, then run Fanatec wheel property)





    and I get the same message every time after I try through Fanatec wheel property page to upgrade firmware

    "device connected "

    "Default Hex file loading failed"

  • Update

    Also tried with another pc,

    some problem...

    "Device connected "

    "Default Hex file loading failed"

  • Jack FruhJack Fruh Member
    edited August 2020

    Thats a bummer.

    Sounds like you'll need to RMA the unit, which you can do from the fanatec site on the top right under your profile, is a link to your products, you'll need to open a case.

    From experience, you'll need: Serial Number & screenshots or a video of the failure.

    Also I assume you've followed this guide

    Specifically on Page 9, the note that says "the load hex file" button is not needed.

    Also for the sake of completeness, Did you install the driver to the default location, and not any other location or drive letter?

  • Thanks again @Jack Fruh for the advises

    1. Tried from my profile to report the problem regarding the DD1,

    but the form does not work...I only get the message "Please enter a message and a subject", while a message and a subject is already entered..

    So how do I gat in touch with the technical department to solve this issue ????

    1. About page 9 yes I agree the button is not needed but the button next to it "Flash firmware" is unavailable.

    1. Yes the driver is installed in the default location C:\programe files\fanatec .....etc

  • From that screenshot, you would click "Connect" and then "Flash Firmware"

    I assume you have done that, but my best friend did miss that detail, so he was in a loop where he thought he was updating, but never did!

    For the support ticket, if you bought from US I think the link to your products is

    Its on the main page, on the top right, look for "my account" then "My Products" - each product will have a "support" button to the right of it.

  • Flash Firmware is not even available.

    What about support ? In the Fanatec page you only keep remaining in a loop constantly asking you : ""Please enter a message and a subject"

    I can't reach support... that's not nice..

  • Still cannot reach support !!!!

    What's going on???

  • Hello, I have the same problem, my dd1 has stopped working and the technical support does not contact me, when I turn on my dd1 I get these 2 messages

  • I open a ticket 3 days ago, I read it could take more than 1 week to help you good luck.

Sign In or Register to comment.