[Resolved] My DD2 is not working out of the box.

I received my DD2 wheel yesterday . The excitement didn’t last very long! After the initial start up it prompted to install the new firmware (v670 I believe). That worked out ok . After the system restart the wheel went into calibration mode but for some reason I couldn’t use the wheel input to calibrate. It seams that it doesn’t recognize the down push on the joysticks button on my 918 RSR wheel. ( It always worked on my CS v2 base). So I used the settings menu to center the wheel instead . The next prompt was to upgrade the motor firmware. That didn’t work ! The upgrade window is to small to read the truncated message, starting with "Not....“ I guess "Not connected to device ...or motor“. The hourglass icon didn’t change for 15 min. and the motor fan kept running at full speed . I had to restart the base eventually and tried the update a few times without a different outcome. I also tried the previous beta version of the driver as well, but that didn’t work either. Now I’m stuck with a "new DD2 wheel base not working out of the box“. Any help would be greatly appreciated.


update: Following some suggestion I read on this forum .....

I unplugged all USB devices , deleted the firmware and reinstalled the latest driver. How would you know ! The motor firmware installed at the first try. That solved that problem. Cooling fan is quite now too. Only the center calibration from the wheel using the analog joystick and D-pad doesn’t work but I can use the settings menu. I’m wondering if the button is having a Problem? But still, it shouldn’t be that tricky to get going !


  • Spending all morning and a good part of the afternoon I managed to isolate the Joystick problem. Since it is an analog switch I could use my multi meter and traced the problem down to the ribbon cable connecting the switch to the board. I eventually managed to trim the cable a couple mm to get new contact points . It must be my lucky day managing to solve two problems .

This discussion has been closed.