LED Light Ring Not Working - Xbox Hub - No Connection Xbox One

I have ClubSport Wheel Base V2.5, ClubSport Steering Wheel Universal Hub for XBOX ONE and ClubSport Wheel Rim GT Forza Motorsport. Just purchased everything a month ago. Works great with my PC installed all the firmware updates upon arrival. I realized when looking at the manual that I should have a ring of lights that changes color around the power button. Mine has been dark since I purchased it but it connects fine with the PC. When I plug the USB into my Xbox One S I get nothing. I have tried the two button press to get it into Xbox Mode and nothing happens. Even if the LEDs are defective it should still switch modes. I have tried powering on the Xbox first, the wheel first unplugging and re-plugging in the USB. I am using the USB cable that came with the wheel. It will go through its spinning start up procedure and numbers will flash up on the display... then it sits there like a rock. You can feel resistance in the wheel so you know it is on. If you press any of the buttons nothing happens. You hit the two buttons for mode change and try the buttons... nothing happens. If I go back and plug it into my PC it works fine. Please Help! I can't find any other mention of this issue.


  • to switch modes on the UHX you need to press the buttons on top of the UHX, not the ones from the wheel button clusters. Did you tried the upper buttons on top of the UHX?

  • Hi Maurice - Thanks I had not tried that. I now have a green light in the lower left quadrant but none of the buttons on the front or top do anything. I tried restarting both the wheel and Xbox One.

  • ClubSport Wheel Base V2.5, ClubSport Steering Wheel Universal Hub for XBOX ONE and ClubSport Wheel Rim GT Forza Motorsport

    I think something is wrong with my new setup. After several more hours of trying I still can't get it to connect to my Xbox. I have contacted support 24 hours ago but have heard nothing back! Sometimes the green ring stays (with all portions lit) with the white light on top lit (supposed to indicate it connected with the Xbox One). One time the green light came on in the lower left corner and the next in the lower right. Most times the green ring comes on then goes off a minute or so later. I never have any control with the buttons. I have tried it on two Xbox Ones also. It is very frustrating we purchased two new full setups to use with our business spending about $2100 to upgrade. All the other companies that make up our motion frames and software get back to us within hours. Fanatec is usually a day or so in response times. You know if something happens on-site you will never hear back in time to fix the problem. If anyone has any suggestions please let us know. We will be pulling the wheels off of the frames in a couple hours and going back to the old gear. Our event is this evening and we need to have everything working properly.

Sign In or Register to comment.