My BRAND NEW CSL Elite PS4 steering wheel keeps disconnecting

My Fanatec CSL Elite PS4 + load cell pedals rocked up yesterday.

Was super excited to set it up but was immediately faced with problems.

First thing, updated it with the firmware from the Fanatec website. Then the wheel wouldn't read (the buttons dont read, nor the paddles, LED lights arent showing). The hub still can detect motion of steering .

It seems like steering wheel isn't reading off the hub properly. There are times when it connects and it can read then whilst I'm playing the wheel seems to disconnect and I can't use the buttons, the paddle shifters but I can still steer. I've tried multiple drivers and firmware and still having issues

This is a brand new base and wheel btw. I haven't even got around to using it. Any ideas what it could be? I've already contacted Fanatec but am avoiding sending it back or getting it replaced as I've already waited ages for this.


  • Make sure all pc drivers up to date or make sure device manager sees Fanatec under gaming device

  • Is this on the PS4 or a PC?

    Anytime there are issues that seem to be with the wheel itself, I would check the pins on the wheel to ensure there isn't a bent, broken or missing pin first. If that looks good, try a different USB port.

    If that checks out, uninstall the drivers completely, reboot, and reinstall the drivers using the latest version available. Might want to reflash the firmware as well.

    If none of that works, I think you might have no choice but to call Fanatec.

  • It's on both.

    Checked the pins. All still connected.

    I've done the drivers and firmware so many times now it's safe to safe the wheels actually not working.

    I've contacted Fanatec. Sent them a video as requested and waiting to hear back from them

  • Did you get this sorted.

    Exact same ting happened to me with PC, tried it on PS4 and does not work there at all

    Any ideas Fanatec?

  • I'm having a very similar problem. Wheel arrived yesterday and this has happened from the very first moment the wheel was connected. My wheel seems to disconnect from the base while driving leaving me unable to use any buttons or the shifters. I can still steer, brake and accelerate so it seems to be a connection issue between the base and the wheel. The only difference is that my steering wheel LEDs and screen go crazy and flicker randomly between all numbers and colours.

    Also, my wheel struggles to start up and goes through repeated power up, side-to-side calibration, then restarts and does this again and again and again. The only way I can get the wheel to start up correctly is to disconnect the wheel before switching on, then reconnecting the wheel afterwards.

    These issues occur whether connected to PC, PS4 or not connected at all. I've carried out all the steps here like drivers, firmware, checking the pins. I've resigned myself to this being a hardware issue so after all the excitement of the wheel arriving, I feel quite deflated that I'll probably end up having to return for a replacement. I've heard of all the issues with Thrustmaster reliability, and that was a major factor in me moving to Fanatec. Not the introduction to the ecosystem I was expecting given the premium price charged.

    Guessing nobody here has found a solution?

  • I had this problem when i first got my setup, it was embarrassing at times, i would wreck half the field as we came to the green lights.. A lot of searching and i came across a post talking about a program called "USBDeview" and that clears all the old USB ports that have built up over time, that stopped the problem until tonight and i hit another 3 guys when it disconnected, checked the program and i have a dozen old usb connections.. I have cleared them but it is too late for me now so i will try again tomorrow and give an update... fingers crossed..!!

    I posted this tonight hoping it would help someone... Have fun and hope it works for you all..

  • I have not had one disconnect since running that program.. USBDeview which is free BTW, just google.. I hope it helps.

  • UPDATE....

    the USBDeview did not work for me so i done more searching and came across a post which said go into device manager and untick all of the "allow this computer to turn this device off" ... in the all of the USBs in your list..

    i have been racing for 2 days now and my problem is cured..

Sign In or Register to comment.