Clubsport V3 not registering input until half throttle.

I have had my Clubsport V3 pedals for ~3 months. All has been working well until today. My throttle will not register until I press it half way down. I tried both in Auto and Manual calibration mode, but to no avail. Both places show the throttle doesn't register until I press it is about 50% pressed. I have reflashed the firmware, uninstalled the drivers (even cleaning out the registry) and reinstalled. I have unplugged and plugged back into my computer. I have unplugged all other devices to avoid any conflicts. The clutch and brake work fine. I checked for any pinched cables, and screws that may be loose on the hall sensor (just by seeing if there was any wiggle).

Any help would be greatly appreciated. Thanks

Comments

  • Did you try blowing air or cleaning the sensor?

  • edited October 2020

    Yes, I did get some canned air and blew between the pedal and the sensor in that little gap. Admittedly I didn't have much air left in the can, so it was just a small blast or 2.

  • This is very likely a hardware issue.

    I would first check the magnet in the throttle pedal for dirt or damage and check whether it's still locked in place by the small Allen screw on the underside of the metal block holding the magnet bar. Compare to the magnet in the clutch pedal to see if it has the same orientation as that one, I suspect the the magnet is loose and has rotated a bit so that the 'zero point' of the magnet is only seen by sensor after pressing the pedal (=rotating the magnet) half-way down.

    If the magnet is OK, you could try switching the throttle sensor to the clutch to see if the problem moves to the clutch. If yes, double-check for dirt on the sensor chip and remove it if necessary (could need a cotton swab with some alcohol). Mounting the clutch sensor on the throttle is another possibility to diagnose the issue but that probably won't work because of cable lengths. It would be a good second check, though, but you'll have to unmount the electronics board for that. If the sensor turns out to be faulty, you'll have to get a new one (from Fanatec).

    And since your pedals being only 3 months old, contact Fanatec Support anyway for further suggestions and a possible part replacement under warranty when you've identified the root cause.

  • Thanks for the info. I will check that out. I have already opened a case with Fanatec Support, but have done several times on past things, and typically do not receive responses. The only one I ever received stated I sent the request to the wrong group. Maybe this time will be different. Fingers crossed. I appreciate the response though, and will definitely give this a try.

  • Thanks again to Remco and Alexandros.

    Here is what I tried:

    1. Removed the Hall Sensor from the throttle.
    2. Removed the magnet from the pedal.
    3. Cleaned the magnet and sensor with alcohol
    4. Put everything back together (BTW...those standoffs are a pain to get to stay on :))
    5. Same issue.
    6. Swapped the sensor from the throttle to the clutch and to my surprise both worked.
    7. I swapped them back as the throttle sensor cable is slightly longer and easier to thread properly.
    8. And issue was there again on the throttle, and a new issue on the clutch.
    9. Throttle still only starts registering after half way, and now clutch registering slightly whiteout pressing it.

    It is now fixed. How:

    1. The tolerances on the sensors seem to be so slight. I backed off the screw almost an immeasurable amount on the clutch and that fixed the issue that started with the clutch. I tightened the screws a slight bit on the throttle and now all working. Backed off a little to where it seemed I had started and things continue to work.
    2. So long story short. If you are registering a little throttle or clutch for some reason back off the screws a slight bit, and if the throttle isn't registering early enough tighten slightly. At least it worked out for me.

    Thanks to those who posted suggestions, it was greatly appreciated.

  • I may have spoken too soon. I think I may have a bad hall sensor. I can get it to work for a while, but issues starts again.

  • If fiddling with the mounting screws of the Hall sensors changes their working, perhaps the PCB of the Hall sensor is damaged and by changing the stress on the board you influence the electric contacts on the board. Either way, it sounds like you should start an RMA for a new Hall sensor.

  • edited October 2020

    You can show in the picture which screws you adjust, improve ranges, you described it very nicely, but I do not fully understand what screws are in question?

    Okay, I read the topic to the end, the actual one, and it shouldn't have happened, since it's because of the PCB.

  • edited October 2020

    This morning without touching anything the throttle was at 100%. Looks like a bad hall sensor PCB. I think Remco is spot on. Hoping I actually hear back from Fanatec support at some point. I opened up a ticket before posting here that included a video of what was going on. Has anyone had luck with getting them to respond?

  • Hi Mark,

    Tech support is a few days behind on tickets. I can see your request (both recent tickets) on the system, please give the team a bit more time to get back to you.


    [Fanatec Community Manager]

  • Thanks so much for the update Dominic. It is much appreciated.

Sign In or Register to comment.