Clubsport 2.5 wheel and v3 inverted pedels not recognized

Hello All,

Brand new to this and ordered the Clubsport 2.5 Forza setup and upgraded to the v3 inverted pedals as the standards were sold out. I have received all of the hardware and loaded the latest driver onto the wheelbase but in the test area of the driver I do not receive any confirmation of pedal movement. Connected just the pedals via USB and all is good see the movements and can operate vibration motors. Re connected everything via RJ12 and tried again see results (no pedals). Connected complete package to Xbox and no pedals. Lastly at no point have I connected the pedal via both J12 & USB, the only connections made have been via RJ12 to the wheelbase (where I am not having any luck) or directly to PC via USB (RJ12 unhooked from pedals). Any help on how to get everything to play nice would be greatly appreciated (I just want to go Sim racing). Thanks

Jim Olson

Comments

  • edited April 28

    Little confused by the way you stated that, but understand you installed the windows driver, and updated to the latest firmware, correct?

    Not sure if this matters, but when you connected either the USB or RJ12....Did you disconnect the other cable from the pedals? Sounds like you did.

    Things to check:

    Is the RJ12 "clicking" into the slot on both the pedals and the wheel base? Is the jack loose at all...meaning, what happens if you wiggle it?


    It sounds like you are only having issues with the RJ12 connection if I am reading this correctly. Can you confirm everything works via the USB and does not work via the RJ12 cable.

    If that is the case, contact support and see what they say. It might only be a bad RJ12 cable, or that port might be blown. In either case, they will fix it one way or the other.

  • Hello James,

    Thanks for the response. Answering your questions in order please see below:

    Correct I installed the windows driver and updated to the latest firmware.

    When testing the pedals I would only connect one cable at a time to them never having both plugged in at the same time. (results success when connected to PC via USB, failure when connected to wheelbase via RJ12)

    The RJ12s each clicked solidly on both ends when I have installed them. I will try wiggling them and the jacks seem secure on both the wheelbase & pedals.

    Correct only having issues with the RJ12 connection. The pedals and the wheelbase check out when connected to the PC via USB.

    One last item of note when I first installed the firmware my only issue was with the pedals all other things checked out. I then reinstalled the firmware & driver in hopes that would resolve the pedal problem and my reward for this is a shifter that now only confirms operation in sequential not in the H-pattern which worked the first time. Once again thanks for response and tips. It looks like I may need to contact support which I am unsure how to do...but will figure out like the pedals. Ready to go racing once this sorts itself out.


    JIm Olson

  • Quick update the pedals still do not function and cannot get the "BRK" symbol to come up in the Tuning menu. Fixed my issues with the shifter and learned a lot on navigating the wheel hub menu and calibration. Any help on getting the pedals to communicate via the RJ12 would be greatly appreciated. One last question can I can connect both devices to my PC via separate USB ports and go I-racing since the pedal communicate via USB? Thanks to all who have responded.

    Jim Olson


  • The pedals and the Wheel base can both be used as separate USB devices. Pedals plugged into USB 1, Wheel Base in to USB 2. No issues at all there. In fact, I ran this configuration for months using my CSP V2's plugged into the USB, with my CSW 2.5 plugged into another. You will see both devices in the game controller menu (Fanatec wheel settings). You should see two entries for your wheel base, and a separate entry for your pedals.

    To contact support, go to the fanatec website, click on the support/FAQ menu at the top. Log into your account, and it should bring up the list of products you have purchased. Click on support for whatever item, and fill out the form. You can also attach a video, pictures, etc. of the issue as well. Anything that helps demonstrate what the issue actually is.

Sign In or Register to comment.