CSL Elite V1.1 pulling hard right with all its force

I am not even sure how to explain this one. I just purchased a CSL Elite V1.1 and got it set up yesterday and man am I having some issues. No matter what sim I use the Force Feed Back on the wheel is all messed up and makes it so I can't play any games at this point. What happens is once I am on track the wheel just pulls as hard as it can to the left and starts knocking and shaking. I have to use all my force just to get it back to center while it fights me the whole time. If I were to let go it would slam back to the left again. I tried to update drivers and it says I have the most recent. Tried to go into PC controllers and when I select the wheel base it changes to (not responding) or the screen just disappears. Beyond frustrated at this point. Anyone have any thoughts? I also tried deleting the firmware and reinstalling with no luck. Starting to think I got a bad wheel base.

Comments

  • Contact support.

  • First: Are you in PC mode or XBOX/PS4 mode?

    Second: I assume that you experience that issue only in a game? That points to calibration issue/ settings issue.

  • Pretty sure I am in PC mode. The power light is red as opposed to green. Per the manual red would be for pc. I have reached out to support. Just waiting to hear back. Definitely something wrong.

  • I had issues like this in GRID 2008 (which is an old game). Which version of the drivers are you using? What wheel / hub? I had to install beta drivers to get the Podium Hub working with that same wheel base.

Sign In or Register to comment.