PS4 CSL Elite red flashing light

Hello,

First time poster.

I've had my CSL Elite PS4 Fanatec wheel since June 2017 and I have hardly used it, maybe 40 hours max!

Today I turned the whole system on and went into the game, everything normal but the feedback didn't work so I reset the race, this has always worked before, but today it didn't.

I ended up turning the whole system off and restarted it. Now all that happens is the first 3 yellow lights come on with the red light on the wheel base unit and then the red light just flashes with three solid yellow lights, the wheel does not move at any point.

I have checked all the cables etc, all good. The wheel has just stopped working :-(

I have sent an email to Fanatec, but while I wait, does anybody know what I could try?

Many thanks,

Comments

  • Did you remember to start the wheel in PS4 mode by clicking on the base's button until the blue light comes on? (Blue light = PS4 mode.....Red light = PC mode)

  • Hi,

    The button does nothing anymore, it's permanently blinking red, it will not respond in any way other than turn the base unit on and off.

    I have since had it hooked up to a PC (my mates as I own a Mac) and he says it does not even show on his PC. This wheel was originally updated in 2017 on his PC, so we know it should at the very least show as plugged in.

    Thanks.

  • Hi,

    I have tried to contact the support team to get my base fixed.

    I have asked the support team (Yannic) twice now for help on returning the base for a fix. I have the serial number but not the invoice number. I bought all my equipment form Fanatec direct from Germany, so it's not second hand! Fanatec can see this if they look in there system on 6-6-2017 when it was all sent out.

    So far all Fanatec have been very unhelpful and not given me the answers I need to return my base for repair. They just say I can fill out the form and get a ticket, but the page will not let me finish without a receipt of sale number, as I told them, I bought the parts in June 2017 and don't have the invoice number anymore!

    I do not understand how to fill in a ticket without the invoice number, can anybody help ??

    I understand I'll have to pay for the repair, and that's fine, I just need help.

    Thanks.

  • OK,

    I ended up ringing Fanatec from the UK, as I couldn't work out how to do it online.

    They were very helpful and the base unit will be fixed within the UK.

    So all good :-)

    Thanks.

  • Wow. You actually got through by phone? Glad to hear it's being sorted out right in your location though.

  • Hi,

    Well, for those that may find this useful, the bill was £95 returned.

    It would seem that it needed a new motor. Very odd considering I'd hardly used it and there was no sign of the unit braking until the wheel just stopped working 2 minutes after turning on.

    Still, it is what it is, if it goes wrong again I'll have it fixed and sell the whole lot on and move to PC on a DD wheel not made by Fanatec as it seems their motors do not last.

    That's me done here, so good luck guys :-)

    Thanks.

  • Hi,

    Another update.

    The wheel has come back, but it does not work.

    The wheel now turns when turned on, but none of the buttons work to control the PS4. I assumed I could just plug and play once back from repair?

    Thanks.

  • Is it in PS4 mode?

    have you asigned it as a controler?

  • Hi,

    It has been working since mid 2017 on the same console.

    It went bad last week and is now back from repair.

    I've plugged it all back in as it should be and nothing works.

    If i remove the shifter I can navigate the PS4, if i plug the shifter back in, the wheel no longer works.

    I I leave the shifter unplugged and go into PCars, I cannot start the game by hitting the 'X' as requested by the game in any colour light on the wheel base. I simply cannot get into the game (even with leaving the shifter unplugged).

    I can however play the game totally with the PS4 pad, so the issue is within the Fanatec system.


    I have a friend that has checked the wheel on his PC (I don't have one) and he says the wheel base is up to date.


    I have changed nothing on the console since the wheel was working.


    Maybe the above has highlighted something??


    Thanks.

  • Hi,

    Does anybody have any ideas for me?

    Sadly because of the virous, I can't have anybody in my house to help fix my rig.

    My mate with the PC can only do so much as he has nothing to do with consoles and not being able to call over, can't take a look.

    So if I can't get it working, I'll have to sell the whole thing as it its no use to me non-working.

    I only play PCars, I don't own any other game, I only use the SP4 as a driving sim, I'm not into any other type of games.


    Can you please help or send me to an open forum that can help.

    Many thanks.

  • OK,

    Now talking to myself, but incase anybody is reading.

    I rang Fanatec today and sent them a video.

    Got an RMA number form them and now ready for collection, again.

  • Update,

    The wheel was sent back to Fanatec last week after a video was sent to them showing the 3 new problems the base had after it was returned to me 'Fixed'. They agreed it was still faulty and collected this time at their cost.

    They have just sent me an email saying they cannot replicate any of the 3 problems my wheel and base had on my video.

    It'll be interesting to see what happens now.

Sign In or Register to comment.