McLaren GT3 V2 rim loses connection to base frequently, no buttons work

James SkinnerJames Skinner Member
edited March 22 in Steering Wheels

Has anyone else had an issue with losing connection to the McLaren GT3 V2 rim after a few laps? All firmware etc is up to date but after running a few laps (usually 3-4, sometimes a bit longer) all shifters, buttons on the wheel etc stop working, but FFB is still present and my CSL Elite PS4 P1 rim works fine. I've also noticed an annoying bump / knocking on some turns which isn't there on the P1 - hard to describe but doesn't feel right.

Usually requires a full restart of base to put right again although a couple of times just going into the driver software seems to wake it back up again, so I'm not 100% convinced it's definitely a hardware issue, either way it mens it's useless for any racing, especially online.

One time the message on rim said 'update firmware' (although as above it's up to date) other times it's just been stuck on what it's currently displaying (ie gear or speed)...

I only took delivery of it 4 days ago, so it's hardly had any usage and this happened pretty much right out of the box, frustratingly. This is happening in AC - don't really use anything else ATM, but pretty sure the issue is with the rim.

Have raised ticket with Fanatec and will post any solutions they offer but expecting rma...

Edit (sw versions):

PC Driver: 402

Wheelbase Firmware:684

Motor Firmware:22

Rim Firmware: 40

Windows 10 64 bit

Comments

  • Personally I think it can be because of poor Quick Release system.

  • Can you make a video that shows exactly how you mount the steering wheel on the shaft?

  • Not sure it needs a video - am just pushing wheel rim onto base and tightening QR until guide line is just hidden as per instructions. Have an aluminium QR system on the way so we'll see if that fixes it....

  • Tighten the QR nut until it reaches the stop, don't worry you can't over tighten the nut.

  • Cool thanks Hristo will try that and see...

  • I have this exact same problem, my gt3 v2 wheel worked perfectly for months and all of a sudden I can’t do more than 3 lapse without buttons and shift going dead, did you get a solution from Fanatec?

  • James SkinnerJames Skinner Member
    edited March 31

    They have asked me to send the wheel back to the UK support team for repair and provided rma ticket etc- I have ordered a Clubsport QR as well as I heard it can fix an awkward bump on turning the wheel which is another issue I've had, that's just arrived so I will test to make sure it's not an issue with the plastic QR - still it's an expensive way to fix something that should be working anyway...

    Support have been very responsive and helpful BTW so get in touch with them is best I can recommend...

  • Paul GapPaul Gap Member
    edited March 31

    hello, I have a similar problem p 3 weeks of use, even made some videos,

    ://youtu.be/2BMi7aUL8oM

    did you also have same a problem?

  • Yes exactly the same problem as that - testing out the Clubsport QR tonight to see if it makes a difference....

  • Paul GapPaul Gap Member

    hi, can you write after some testing time if the new QR helped

  • So far so good, but only did about 20 laps - more testing tonight, what I can definitely say though is that the FFB feels better without the weird bump / knock in the middle sometimes...

  • I have a similar problem, suddenly I lose the FFB and the Oled screen restarts. I have tried several drivers but nothing, always the same. Without QRs, I have a CSW 2.5.

    It happens to me when I turn to the right, until now I have never had the problem turning to the left.


  • I can report that the Clubsport QR seems to have fixed the issue I was having with the disconnects, at least for now, so perhaps there is a QC issue with the new plastic QR that comes as standard. Not exactly a cheap fix though.

  • Paul GapPaul Gap Member

    hi, I am just thinking about buying a metal QR, because the plastic one does not have the right mounting, fanatec should give a discount on the QR if someone has such a problem

  • aiden blakeaiden blake Member
    edited April 7

    hi i've had similar however the screen goes blank for longer. my ffb goes lighter but it is still there and my wheel comes back on within a few seconds and everythings back to normal. The wheel base is still on just ffb is lighter and i can still steer. My pedals still work as they are thrustmaster loadcells but my wheel rim screen is blank I can't shift up or press any buttons. 2-3 seconds later it's fine. Any ideas?

    Must add my wheel base and wheel rim are less than a month old so firmware is up to date.

  • Paul GapPaul Gap Member

    Hi James,metal QR steering and wheel still working properly?

  • Yep still working - not done a huge amount of driving but so far so good....

  • ๐Ÿ‘

  • Bad news - after a few months of use the disconnection has started happening again, even with the metal QR, so the wheel is now an expensive paperweight ๐Ÿ˜ก

  • Yesterday I‘ve received a DD1 for PS and what can I say: Same Problem as u all described. After 1 or 2 laps FFB gets lost. Base shuts off also from time to time. Symptoms show up after driving over higher curbs or in right corners. Other wheels without a plastic QR work well. Thought about buying a metal one but after James last contribution I think about selling the McLaren Wheel. What a shame :-(

  • I´ve also opened a ticket at Fanatec. Will keep you posted.

  • Dear All,

    Short update from my side. I had a good conversation with the support team of Fanatec. They offered me an inspection of the DD (PS4-Version) and the McLaren V2, which I agreed on.

    Will keep you posted.

  • Curious to get an update if you have one. My brand new gt3 wheel is doing the exact same with the csl dd. Very frustrating to have it ruin a race 45 minutes in

  • Dear All,

    update took long as I was on holiday during the DD AND the McLaren wheel was checked by Fanatec.

    They wrote that the QR light had a production failure. Therefore, they replaced it with the metal QR1. Yesterday I drove approx. 2 hours and everything worked well.

    Regards

    Martin

  • Hi,

    Yesterday the same thing happened to me with mclaren gt3 and csl dd. I have sent a ticket to fanatec support.

    What solution did they give you? The product is under warranty.


    Regards

Sign In or Register to comment.