Fanatec Driver 429 (428/427beta before) for CSL, CSW and Podium WB (all wheels)

Marcel PfisterMarcel Pfister Member, Administrator
edited November 11 in Beta drivers

Changelog of driver 429 (hotfix of 428 and 427 beta)

(To see changes of previous versions, look here https://forum.fanatec.com/categories/beta-drivers)


Firmware versions included

  • CSL DD: 1.0.5.3 (NEW)
  • CSL DD Motor: 1.0.1.3
  • CSL DD WQR: 6.0.0.1
  • CSW V1 Base: 687 
  • CSW V2 Base: 687
  • CSW V2.5 Base: 687
  • CSL E Base: 687
  • CSL E Base PS4: 687
  • DD1 / DD2 Base: 689 (NEW)
  • CSL/CSW Motor: 22
  • DD1 Motor: 41
  • DD2 Motor: 41
  • SW McLaren: 32
  • SW McLaren V2: 41
  • Formula V2: 41
  • Podium HUB: 6
  • Podium BME: 18
  • CSL SW WRC: 4
  • CSL UH: 3
  • CSP V3: 1.32
  • CSL EP LCK: 1.10


Driver UI

  • USB pedals now supported by the new UI
  • Improved rotary input detection in UI
  • Fix for jumping / jittering sliders
  • Fixed missing hint fro [APM] on Steering Wheel Page
  • Fixed wrong hint for [MPS] on Tuning page
  • Fixed UI not re-opening after closing Firmware Manager
  • Fixed vibration tests not working if BLI is not set to OFF


General

  • Added/improved support for ClubSport SW UH/UHX V2
  • Added/improved support for ClubSport SW BMW V2
  • Added/improved support for ClubSport SW RS


CSL DD

  • Fixed issue where BMW GT2 funky switch had ghost inputs to all other buttons. Slight draw back, input can have very short interruptions during long press.


P DD

  • Fixed high torque not available with some wheels which have a metal QR mounted.
  • Fixed FF, FOR, SPR, DPR and FEI not affecting the FFB directly on setting change.
  • Fixed NFR getting deactivated after changing wheel base mode.


Known Issues

  • Podium wheel base jolts can happen on ITM or analysis screens of the wheel base display. A workaround is to use the default screen with “Fanatec” logo while driving. We are still working on a fix which needs an extensive re-write of the P DD firmware which is why it takes so long.
  • CSL E WB, CSL E WB 1.1, CSW V1, CSW V2 are currently not shown correctly in the new UI and the old UI has to be used as a workaround until we fix it in the next version. The old UI can get accessed via the "USB Gamecontroller" overview of Windows. (fixed with 428)


How to use the new function to collect log files

  1. Open the new UI via the desktop short cut or search for "Fanatec Control Panel".
  2. Go to the settings page.
  3. Press the "Collect Logs" button.
  4. This may take ~30 sec to collect all log files and put them into a .zip archive.
  5. The folder with the .zip will appear and you can upload it to the forum when reporting an issue.


Download:


Test motor firmware for Podium DD

  • Improves motor calibration to remove sticky feeling on direction changes. People which liked to remove the motor calibration with the last versions should give this firmware a try.
  • Fixes issue of wheel moving slightly back and forth after resting it in some positions.
  1. Open driver UI
  2. Go to the update page
  3. Open firmware manager
  4. Click on manual update in the top right
  5. Click on motor firmware update
  6. Use the three dots to browse the correct file, note there is one for DD1 and one for DD2
  7. Flash firmware


Compatible FanaLab Version:

https://forum.fanatec.com/discussion/23638/fanalab-1-57-4-download-previously-1-57-2-post-your-feedback-here/p1


How to report issues:

If you report a driver or firmware issue, please make cross checks:

  1. Update driver and FW separately to isolate an issue and find out if its caused by driver OR firmware.
  2. Which driver OR firmware does show the issue
  3. Which driver OR firmware does not show the issue
  4. Check if you can reproduce the issue again if you go back to the version which seems to have cause the issue
  5. Post the answers gathered from the questions above + a short description of the issue including the following information:
  • Wheel Base Model (product ID): ...
  • Steering Wheel Model (product ID): ....
  • Driver Version: ....
  • Base FW Version: ....
  • Motor FW Version: ....
  • Wheel FW Version: ....
  • FanaLab Version: ....
  • Driver/FanaLab installed on C: drive or else?
  • With driver related issues collect log files and zip them from C:\Users\Public\Fanatec Logs


«134567

Comments

  • Thank you Marcel :-)


    The DD1 / DD2 firmware is the exact same as 41a we patched in 423 right they appear identical?


    Cheers!

  • edited November 8

    The Motor Firmware is identical, yes.

    The Base Firmware however has significant other fixes as listed in the changelog.


  • Thank you Maurice for the quick response and clarification. Yes the change log is great I found the thread today in recent discussions and got started.


    Cheers!

    David

  • Updated once again from 423 to 427, I'm really liking the UI updates, the tuning presets now instantly change just like the old UI did and the pedal interface finally is working properly so I dont need to use the V3 pedal menu anymore. Appreciate the rapid updates !

  • The UI keeps disappearing on Windows 11.. Like it has quit (icon in taskbar disappears), but sometimes it comes back by itself.

  • Updated my csl DD and now it finally works without ghost buttons on the BMW wheel 😃👍

    Seems like my right paddle shifter is working to. 👍

  • In PC Mode: "No Fanatec Device Found" with Podium F1 - PS4

    I followed the instructions below:

    1. Update driver and FW separately to isolate an issue and find out if its caused by driver OR firmware.

    I updated from 410 to 423 and then the problem appeared. Deleted 423 and reinstalled 410 and the problem didn't go away. Reinstalled 423 and the problem still there. Installed 427 and the problem still there.

    Problem: In PC Mode: I get "No Fanatec Device Found". If I switch to Comp V2.5 then all components appear (Wheel Base = Podium Wheel Base DD1, Steering Wheel = Clubsport Formula V2, Pedals = Clubsport V3 (connected to wheel base), Shifter = Clubsport series (7 spd shifter with sequential mode). I tested the wheel in Asseto Corsa Competzione, Assetto Corsa and RaceRoom and it is useable. I could not get it to work in AMS2. Wheel buttons and pedals all work, but wheel rotation is not detected. I tested the wheel on the PS4 and it works in both PS5/PS4 (GT Sport) and in Comp PS4 (PCars2) modes.

    1. Which driver OR firmware does show the issue

    Problem now appears in Driver 410 (Last version it worked without problem, but problem persisted after I deleted 423 and reinstalled 410), 423 and 427

    1. Which driver OR firmware does not show the issue

    As a last resort I deleted 427 and Fanalab and reinstalled 400 and it still failed to detect a controller in PC mode, but the Comp V2.5 mode is available and working. So, it seems not driver related? I then reinstalled 427. I tried to open a support ticket for the prblem but the website keeps on kicking me back to add a title and erases all the information I put in. Tried about 10 times before I gave up.

    1. Check if you can reproduce the issue again if you go back to the version which seems to have cause the issue

    423 seems to have caused the issue and it continues to be a problem on 410 and 427 and now on 400 too

    1. Post the answers gathered from the questions above + a short description of the issue including the following information:
    • Wheel Base Model (product ID): Podium Racing Wheel F1® (P_RW_F1_US)
    • Steering Wheel Model (product ID): Clubsport Formula V2
    • Driver Version: 427
    • Base FW Version: 688
    • Motor FW Version: 41
    • Wheel FW Version: 41
    • FanaLab Version: 1.57.4.0 (currently not using Fanalab due to crashing my games) Currenly Fanalab shows the DD1 base in the picture but descibes it as ClubSport Wheel Base V2.5 because it also shows nothing in PC Mode
    • Driver/FanaLab installed on C: drive
    • With driver related issues collect log files and zip them from C:\Users\Public\Fanatec Logs



  • Updated my csl DD, with driver 427 and Fimwares 1.0.5.3 and now it works without, having to calibrate every time the steering wheel is changed

    however have a little problem with BMW M3 GT2 when it's cal. turns from 0 to the left -3 or to the right 1 it feels like there is a small bulge when it is in the center otherwise it just works super max

    --------------------------------------------------

    CLUBSPORT V3

    i have found that i can not get rumble on Throttle it works when i test it

    or is it an end position in the tuning menu that I have to make

    it works 100% on the brake


    Thank you very much for your time and help!

    about really many times thank you for your help from the other day. 😀😀😀😀😀

  • edited November 9

    Rumble Tests are not working when you have set BLI to anything other than OFF.

    So disable BLI and it will work again.

    It's currently a Bug in the new UI which is being looked at to fix so it's working like in the old UI. No ETA yet though.

  • Does this latestest firmware correct the issue with the Indicator automatically switching on in GT Sport when using the Endurance Button Module with APM on the DD1?


    Thanks

    Nick

  • sorry to ask again I have a question


    Updated my csl DD, with driver 427 and Fimwares 1.0.5.3

    I received csl dd here D 25-10-2021 was standard setup (11NM)

    with csl dd with boost kit 180 bundle (8Nm) after the last update, it seems that it is set down in Nm. It feels like it can not get over (5Nm) or is it just me who can not just figure it out


    Thank you very much for your time and help!

  • Marcel PfisterMarcel Pfister Member, Administrator

    New driver 428 replaced 427 beta in the first post of this thread.

    • Fixed CSL E WB, CSL E WB 1.1, CSW V1, CSW V2 not getting shown correctly in the new UI


    Download


  • Marcel PfisterMarcel Pfister Member, Administrator

    Can you capture it in a screenshot or video?

    Would also be great if could provide log files, either through the settings page of the UI if you manage to reach it or by putting the files in this folder into a .zip: C:\Users\Public\Fanatec Logs

  • Marcel PfisterMarcel Pfister Member, Administrator

    Great to here, thank you for the feedback and sorry that it took some tires to fix it.

  • Marcel PfisterMarcel Pfister Member, Administrator

    You can try the following things:

    • run the repair function of the driver installer while the device is plugged in and running in PC mode.
    • change to a different USB port
    • check in the wheel base is shown in the windows USB Gamecontroller overview when in PC mode
    • check in device manager when plugging USB in and out if a device appears and look if there might be an issue shown.
  • Marcel PfisterMarcel Pfister Member, Administrator

    The pictures you've posted don't match your issue description, maybe you've wanted to show something else instead?

    Please double check the tuning menu settings through the steering wheel and make sure FF and FOR are at 100% and FFS is on PEAK.

    Do you get a BoostKit logo on the wheel base page?


  • super here is FanatecDiag for you

    I have installed driver 428

    thank you very much for the setup you sent 😀

  • Disable LINEAR Mode and set it to Peak. Then you get your 8Nm back. Otherwise it's indeed limited to 6Nm.

  • super it's done

    now i'm just so happy it works and it's nice to use again. there is power and no bump on the wheel or base

    i super good and quick to help 1000 thanks to you all👍️😀😍

  • CSL DD with 428, base firmwar 1.0.5.3 and BMW GT2 v1, still not ok. I still get false button presses, not as often but they are still there. Tested on the wheel page of the driver. It's almost completely limited now on the white and left green button as well as on the purple and right black button. The false presses are registered as well as pressing the funky switch as using the dpad directionals.


  • CSL DD with 428, base firmwar 1.0.5.3, I myself have the same model. BMW GT2 v1,

    now. For me

    play PC games with BMW GT2 v1

    need for speed payback

    need for speed Heat

    Dirt Rally 2.0

    Automobilista

    KartKraft

    Nascar Heat 5

    Project Cars 3

    RaceRoom

    rFactor 2

    Torque Drift

    I have no problems. It just works super well

  • Can confirm my 918R is fixed now on DD1, have full torque again. Thanks for this! Was on the version immediately before the hotfix for it; went straight to this.


    Also applied motor firmware. Feels good, but need more time with it - only got a few minutes on it, and haven't used the 918R for so long, need to try the 911 too. :-)

  • Attila SoósAttila Soós Member
    edited November 9

    Hi,


    After some weeks I tried again playing with RaceRoom, Automobilista2, EuroTruck2. But with this games the V3 break pedal not detected.

    Windows11, Fana Driver428,

    Only the iRacing working fine. Is this a Steam problem, or others?

    Fanatec Driver detected the pedals, but under Steam simulators the break does not want to work. Gas, Clutch ok.

    With Windows10 and 423 driver was all ok with this games

    I connected the pedals by USB and after that to Base, but the situation is same.

  • Problem maybe solved, in the driver I chenged the Pedal Settings from AUTO to MANUAL and I got back the break pedal under RaceRoom. Hmmmm.

  • Yesterday I was forced by message in LED display to update PC driver and then base firmware to 1.0.5.3 version. I had some problems with that but finally I get all updated and I saw for all my components that driver is up to date.

    After few laps in ACC I noticed that paddles are not reacting on my inputs, gear changes, buttons are not working but steering is working. It was few times for 10-15 seconds and after it I quit game and I see that my wheel is not visible on detected devices list.

    When I power on base without wheel attached it is discovered and power on in PC mode as it was before.

    When I plug in wheel to base it makes base disappear. When I power on base with wheel attached it is not appearing in devices list and it is not in PC mode but in Compatibility mode.

    I tried already PC driver 412, 415 and 427. The same behavior for all PC drivers.

    Any ideas/solutions?

  • Marcel PfisterMarcel Pfister Member, Administrator

    can you please provide a video of showing it in the driver

  • Thanks Marcel!


    I'm assuming its only the PC driver itself that's changed with 428? Still DD1/2 base FW of 688 and is the patched motor FW 41a included in 428 now or does it still need the patch separate, it didn't mention in the post?


    Cheers,

    David

  • Marcel PfisterMarcel Pfister Member, Administrator

    If the brake works fine in some games and the driver but not in some others then it's not very likely to be caused by the firmware, also because no one else so far seems to report it, but we can double check.

    Which firmware do you have on the pedals?

    You can downgrade the firmware to see if it helps by connecting them via USB, then going to the update page of the firmware manager, choosing manual mode in the top right and clicking on the pedal firmware update. The updater will open and then you can select the older firmware file via the three dots.

This discussion has been closed.