Fanatec Driver 439 (Public Release) (435-437 before) for CSL, CSW and Podium WB (all wheels)

Marcel PfisterMarcel Pfister Member, Administrator

How to report issues:

If you report a driver or firmware issue, please make cross checks:

  1. Update driver and FW separately to isolate an issue and find out if caused by driver OR firmware.
  2. Which driver OR firmware shows the issue
  3. Which driver OR firmware does not show the issue
  4. Check if you can reproduce the issue again if you go back to the version which seems to have caused the issue
  5. Check if the issue is related to specific settings of for example the tuning menu. Is it happening more or less with a specific setting raised or lowered?
  6. Post the answers gathered from the questions above + a short description of the issue including the following info:
  • Wheel Base Model (product ID): ...
  • Steering Wheel Model (product ID): ....
  • Driver Version: ....
  • Base FW Version: ....
  • Motor FW Version: ....
  • Wheel FW Version: ....
  • FanaLab Version: ....
  • Tuning Menu settings
  • Driver/FanaLab installed on C: drive or else?
  • With driver related issues collect log files and zip them from C:\Users\Public\Fanatec Logs


Changelog since driver 434

Firmware versions included

  • Podium DD1 / DD2 Base: 691 (NEW)
  • Podium DD1 / DD2 Motor: 42
  • CSL DD / GT DD PRO Base: 1.1.4.5 (NEW)
  • CSL DD / GT DD PRO Motor: 1.0.2.2
  • CSW V1 Base: 689 (NEW)
  • CSW V2 Base: 689 (NEW)
  • CSW V2.5 Base: 689 (NEW)
  • CSL E Base: 689 (NEW)
  • CSL E Base PS4: 689 (NEW)
  • CSL / CSW Motor: 22
  • Podium HUB: 6
  • Podium BME: 20 (NEW)
  • CS SW Formula V2(X), V2.5(X): 44 (NEW)
  • CS SW RS: 2
  • CS SW BMW V2: 2
  • CS UH V2 / UHX V2: 1
  • GT DD PRO SW: 7
  • CSL SW McLaren GT3 V2: 44 (NEW)
  • CSL SW McLaren GT3: 33
  • CSL SW WRC: 4
  • CSL UH: 3
  • CS P V3: 1.32
  • CSL EP LCK: 1.10
  • CSL P LCK: 1.60


Control Panel

Since 439:

  • Fixed issue where driver switches to Auto Setup on its own, seemed to be caused by steering input changes during
  • Fixed driver UI crash when using GT DD + P1 on steering wheel page
  • Improved CSP V1/V2 via USB and via WB implementation in the driver UI
  • Fixed issue where save/load function fails when turning the wheels before or after update

Since 437:

  • Fixed shown blank message when starting UI while in PS or XBO mode
  • Fixed Clutch Bite Point for PDD related to FanaLab issue
  • Fixed driver update notification not being clickable
  • Fixed CSP V2 inputs not shown correctly in UI when connected via USB
  • Fixed CSW V2.5 incorrect max SEN when in standard tuning menu mode
  • Fixed mouse Emulation stops working after re-attaching BME
  • Fixed ghost input when changing from BME on PHUB to other wheel
  • Fixed different Formula V2 Mouse Emulation picture on old belt bases

Since 435 and 436

  • Removed SHO setting on tuning menu page for wheels without vibration motors
  • Fixed handbrake input not shown when connected to USB pedals
  • Improved start up time of Fanatec Control Panel
  • Adjusted "Hide" tab option in pedals and shifter tab where it gets off-screen when using small resolution
  • Adjusted option for map SEQ shifter to paddle be visible in SQ and H-Mode
  • Changes to prevent anti-virus software to flag driver as a thread
  • Fixed ACP mode on BME re-setting itself to CBP mode every time switching to a different tab
  • Added handbrake calibration buttons when handbrake is plugged into base and no pedals are connected


General

  • Fixed mouse cursor drift in GT Sport
  • SHO setting now hidden in tuning menu for wheels without vibration motors
  • Added FFB stop when disconnecting USB
  • Several fixes/adjustments for Clutch Bite Point mode


CSL DD (since 439)

  • Fixed issue with shifter calibration


Podium DD

  • Fixed error message of "exceeded maximum rotation" getting shown without reason


Button Module Endurance

  • Added compatibility to CSL Elite WB PS4
  • Improved tuning menu text consistency with Podium DD display
  • Fixed LEDs being too bright since v19 firmware
  • Fixed rev LEDs not working when attached to UHX V2


Formula V2

  • Improved joystick input at min/max position


CSL WRC Steering

  • Fixed not working PlayStation button in PlayStation comp mode


CSL UH

  • Fixed QR detection of CSL UH when connected to CSL Elite or ClubSport base


Known Issues

  • Podium wheel base jolts can happen on ITM or analysis screens of the wheel base display. A workaround is to use the default screen with “Fanatec” logo while driving. We are working on a fix which needs an extensive re-write of the P DD firmware.
  • Natural Friction (NFR) can create a weird FFB sensation and not smooth feeling after some time, we suggest to set NFR to OFF in case you experience this issue. You can raise the Natural Damper (NDP) slightly to compensate for less/missing NFR.
  • When entering a game menu while driving in some games it can happen that the FFB effect doesn't get cancelled which results in the wheel turning to one side.


Compatible FanaLab Version:

It's mandatory to use FanaLab 1.61.3 or newer with this driver to prevent tuning menu settings being saved/loaded with slightly different settings.

https://forum.fanatec.com/discussion/25118/fanalab-1-63-download-post-your-feedback-here/p1


Download


«13456718

Comments

  • I have a bad feeling that weird FFB sensation won't be fixed like jolts haven't been for over two years already.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Correct we are still investigating and need detailed feedback.

    We've found an issue with NFR and suggest to keep it at OFF for now but we also need to know if that was the reason for everything which got reported or if there is more.

  • Marcel, if it helps, I have the problem that the steering wheel turns only when it feels like it. And NFR I have it OFF. I will still test this controller and report back. Greetings

  • Marcel,

    are the P1 wheels with a Podium DD supported again with basefw 691?

    Matthias


  • Maurice,

    sorry but that's just BS. Of course they they were supported and should still be. CSL BMW and CSL WRC state Podium combatibility and they are nothing else than P1 wheels. Compatibility stopped after base firmware 675.

  • edited January 28

    You mis-read my comment and should carefully read it again.

    I said "they were never not supported" which means they were ALWAYS supported, also after 675...

    So yes of course they work just fine with this driver and firmware but they also worked fine with every driver and firmware before, compatibility never stopped.

  • The discussion has ended and it has been rewritten.

    Random jolts and rattling in fanatec podium dd occur above constant torque

    It is divided into two types, one occurs in the quick release

    This can be solved by tightening the included bolts.

    However, there are random jolts and rattles that occur even when joining the included bolts.

    This happens randomly in game when you step on a collision effect or curb.

    In the case of dd2, regardless of peak or linear, it can be seen that it occurs when the FFB intensity is over 51% through the fanatec force feedback test.

    When it is below 50%, it is tested very gently, but when it is above 51%, it rattles rapidly.

    I've tried fanatec dd1 and dd2 and dd2 used two as an initial bad exchange and had the same random jolts and rattles in-game.

    It is alleviated by lowering Fei, but occurs again by increasing the FFB intensity.

    In my opinion, this problem seems to occur in the effect over a certain torque.

    In my opinion, this is alleviated by lowering Fei, but it occurs again when the FFB intensity is increased, so setting Fei is not a fundamental solution.

    I've searched a lot of information and the same thing happens even if I leave the fanatec logo on the display. This doesn't seem to have much to do with the display screen.

    I hope this is not a hardware glitch I hope fanatec can fix this.


    always thank you for your hard work


  • Maurice,

    mea culpa, didn't read your comment carefully enough ;-)

    My question still is, will the Podium base firmware 691 support the P1 wheels again, because beginning with Podium base firmware 68x attaching a P1 wheel to a Podium base will make the base freeze within a minute. Let's wait what Marcel has to say.

    Have a nice weekend

    Matthias

  • That should never have happened and didnt happened to anyone in the test Team, the P1 wheels always worked in every 68X Firmware just fine and you are the only one ever reporting this issue so it sounds more like your hardware is defect and you should contact the support.

  • "...We are still working on a fix which needs an extensive re-write of the P DD firmware which is why it takes so long..."


    Can You say anything when that new DD driver could be out?

    Summer, christmas, 2022, 2025 ?

  • On my CSL DD the NFR setting was not the issue. I have NFR off since october and had random jolts. My fix was a better quality USB cable. It looks like the provided one has shitty quality.


  • With all the testing needed, I am sure they will let you know once they are ready. They are only doing their job and so no need for sarcasm. Give them time please. If you are not willing to wait and be patient, there are other options out there.

  • This update corrected the lack of LED & Telemetry on AC (from Driver 434 to 435).

    Works as intended in PC mode with AC, ACC, rF2. Minor inconvenience with R3E, had to rebind all the buttons/pedals/etc for each wheel. The wheel also feels more responsive & weighted based on driving conditions than driver 434. The FFB feels great so far. However, there still is jolting, had 1 over a few hours of use.

    DD1 PS4 F1, PBME, Clubsport Hub

  • Hello everyone, no sarcasm!

    We, who share our experiences and problems here in the forum, do so because we believe in the product, want to help eliminate the errors and thereby improve it!

    Not all are official testers or influencers who received the product for free.

    Personally, I am now very disappointed, I have switched my complete "Race Setup" to Fanatec, and also bought a new V 1.5 handbrake because I always had problems with the 1.0 and all at my own expense.

    In the beginning I was quite satisfied and believed in the prophecy that the problems would be recognized and fixed in the future. At the moment I only see desperation and helplessness and I am considering going back to version 415 including the FW.

    So I ask myself what happened at Fanatec? I don't get it, if the FW 689 doesn't have the problems of the FW 690, why don't I go back and build on that????

  • One bug to report, I did an update to v435 and latest firmware on DD Pro w/McLaren GT3 v2 and it all took fine however it blew away all my setup settings despite me having told the installer to keep them.

  • That wasn´t sarcasm.

    I know Fanatec´s policy that they don´t tell anything until there is something to tell.

    That DD driver been under coding for long time, so is there something wrong to ask if it´s already near to release 🙄

    There is always some a**lickers to defend manufacturers...

  • People who have tried the 434 beta driver and found problems were not taken seriously and designed as placebo ... least install a beta driver or update their drivers and firmware regularly and thus give no feedback on drivers or firmware problems because it Just a few taste and exactly these are not taken seriously when they report mistakes ... what the people report now as a problem was misleaded before beta testers, ignored and the users for stupid ... ask me then the bata ask Provides to test drivers if only the opinions of Fanatec Fanboys count and in the end is that the driver or firmware are faulty? Well, who has no problems makes themselves which, you're good that you are not the only ones to operate simracing ...

    • Podium wheel base jolts can happen on ITM or analysis screens of the wheel base display. A workaround is to use the default screen with “Fanatec” logo while driving. We are still working on a fix which needs an extensive re-write of the P DD firmware which is why it takes so long.

    There’s a lot of us that have been waiting about 3 years for a fix for this. 3 years!!!! I think we have every right to be unhappy about this. After all the ones that are affected have spent a premium on this equipment and expect it work as advertised with all features working and usable.

  • It's 2 years, not 3. The Podium DD was released in April 2019 so it's not on the market for 3 years. Issue came in December 2019 or Januar 2020.

    But yes it's an annoying issue but it's under heavy investigation with priority for sure, Fanatec knows that this is a serious issue.

  • Utter nonsense. Over two years to a fix a buggy driver is an unacceptable amount of time. If you disagree then you are the outlier. Suggesting that affected users simply ditch their high end wheels is remarkably condescending. I suggest you ask your self - would you sit patiently waiting for over two years for your wheel base to work correctly without getting frustrated?

  • Ok Fanatec, you have heard from the unhappy souls, so please continue to find the issue of the problem, which I am sure you are. Keep at it!

  • PBME firmware v20 fixed flag leds issues ! Thanks for this !

    Brightness still too high in my opinion while gaming in a pretty dark room but note that the value can be adjusted within a fanalab game profile (directly in the .pws file)

  • Brightness is now exactly the same as in v18 and always before.

  • I never says it wasn't 😉Just said that it's still too high in MY opinion 😎

  • Unable to calibrate handbrake when not using fanatec pedals. I can see the input but no option to calibrate. Handbrake is connected to dd2.

  • Did you updated the Base Firmware to 691?

    This should be fixed with that Base Firmware.

  • BranddanneBranddanne Member
    edited January 29

    Ah ok. Didn't see it in the changelog so I didn't bother. Will try right away


    Edit:

    still the same problem with driver 435, base fw 691

  • With the new driver 435 i have a weird bug that on my mclaren gt3 v2 on v44 the right analogue pedal is most of the time stuck at 99 and if i push it back its 0. There are only those 2 positions doesnt matter where the pedal is. i went back to driver 434 and sw v43 and all works fine again

This discussion has been closed.