FanaLab 1.64.5 - Post your Feedback here

Marcel PfisterMarcel Pfister Member, Administrator
edited June 3 in FanaLab

How to report issues:

  • List which hardware, driver and firmware you are using
  • Cross check with other settings, games and wheels to see if it's a general issue or specific with to a game, wheel or setting.
  • Is it happening with just one game (which one) or all you tried.
  • Go into detail how we can reproduce the issue.
  • Post screenshots or videos if needed.
  • In case of a FanaLab crash, use the "Collect Logs" feature under "Settings" and upload them here.


Changelog of FanaLab 1.64.5

  • Fixed: Crash on device power off.
  • Fixed: Crash on FanaLab start.
  • Fixed: Crash when deleting custom game image.
  • Fixed: Crash in F1 2021.
  • Fixed: Display and LED flicker when shifting or pressing a button in F1 2021.
  • Fixed: Default profile loading issue and profile preview on start.
  • Fixed: Several issues with ITM and analysis page selection.
  • Fixed: Engine vibration not working.
  • Fixed: MPS setting missing on the Tuning Menu page on BMW M4 GT3.
  • Fixed: Not reverting to Normal color when switching through Tabs and changing the LED on BMW M4 GT3.
  • Fixed: Button LED colors get re-set on FanaLab start on BMW M4 GT3.
  • Fixed: missing recommended profiles.
  • Fixed: Issues with rFactor 2 telemetry.
  • Fixed: rFactor 2 telemetry plugin copy issue.
  • Fixed: iRacing brake balance rounding issue.
  • Fixed: Vibration checkbox not enabled on Save/Load panel even when USB Pedal is connected.
  • Fixed: TelemetryDataExtra.xml not created.
  • Improved: WheelSpin and WheelLock for ACC.
  • Improved: Custom game image selection.
  • Improved: Profile preview behavior.
  • Updated: Hide BLI unless CSP V3 pedals are used.
  • Updated: FFS setting on P DD. Locked when WB is in Low Torque mode.
  • Updated: Strings and hints.
  • Updated: Pitlane warning on the 3-digit-Display now looks like this: ]P[ - Pit Limiter engaged still looks like this: [P]
  • Added: Automobilista 2 Telemetry Data 
    • DRS
    • ERS
    • ABS Setting
    • TC Setting
    • Pit Limiter


Known issues/limitations:

  • iR tyre temps sometimes differ from black box.
  • rF2 brake bias can differ very slightly.
  • R3E tyre temps slightly differ from HUD.
  • F1 2020 and 2021 tyre temp differs from dash to HUD.
  • FanaLab not starting -> see hotfix download below


Compatible driver

https://forum.fanatec.com/discussion/26105/fanatec-driver-442-for-csl-csw-and-podium-wb-all-wheels/p1


Download


Optional Hotfix for crash on startup

Fanalab 1.64.5 can crash on Startup when the CustomGameConfig.xml is not present in the TEMP folder which is only the case for some people. In this case you can download the additional file below and extract it into your FanaLab installation directory to replace the fanalab.exe


«134567

Comments

  • Had to downgrade Fanalab. This new version don't even start.

  • A bit more Information would certainly help.

    Please see in the first post how to report an issue.

    And please also upload Windows Event Logs when you experience any kind of crashes.

  • edited June 3

    Oh, very sorry for this. I didn't upload any logs because sinse fanalab don't start, I don't know where to get logs.

    I was using fanalab 1.61.3 with 440 drivers.

    I first updated to the new 442 drivers released today and this version of fanalab was still working.

    Then I updated to the fanalab 1.64.5 and it didn't start. I rebooted, removed fanalab and installed it again. Still don't start.

    Uninstalled and installed 1.61.3 again and it's fine.

    Is there any folder that I can get the logs to upload here ?

    Forgot to include some info:

    • DD1, drivers 442
    • Windows 11
    • Not game specific


  • edited June 3

    Open Windows Event Manager, click on the arrow for Windows-Protocols, click on Applications and search for the red error messages which are related to a FanaLab crash and then export them and post them here as a zip archieve, otherwise its impossible to analyse.

  • Hope this is what you need. I'm not a pro windows guy, I only use windows on the gaming pc and never used this event viwer before.


  • Got the error text:

    Faulting application name: FanaLab.exe, version: 1.64.5.0, time stamp: 0x629971b9

    Faulting module name: KERNELBASE.dll, version: 10.0.22000.708, time stamp: 0x8792334c

    Exception code: 0xe0434352

    Fault offset: 0x0013f192

    Faulting process id: 0x3e9c

    Faulting application start time: 0x01d8774feb40ddfe

    Faulting application path: C:\Program Files (x86)\Fanatec\FanaLab\Control\FanaLab.exe

    Faulting module path: C:\Windows\System32\KERNELBASE.dll

    Report Id: 2007b91b-aa3f-4bc7-ba43-4b0cc387ee46

    Faulting package full name: 

    Faulting package-relative application ID: 




    Application: FanaLab.exe

    Framework Version: v4.0.30319

    Description: The process was terminated due to an unhandled exception.

    Exception Info: System.IO.DirectoryNotFoundException

      at System.IO.__Error.WinIOError(Int32, System.String)

      at System.IO.FileStream.Init(System.String, System.IO.FileMode, System.IO.FileAccess, Int32, Boolean, System.IO.FileShare, Int32, System.IO.FileOptions, SECURITY_ATTRIBUTES, System.String, Boolean, Boolean, Boolean)

      at System.IO.FileStream..ctor(System.String, System.IO.FileMode, System.IO.FileAccess, System.IO.FileShare, Int32, System.IO.FileOptions, System.String, Boolean)

      at System.IO.FileStream..ctor(System.String, System.IO.FileMode, System.IO.FileAccess, System.IO.FileShare, Int32, Boolean)

      at System.Xml.XmlWriterSettings.CreateWriter(System.String)

      at System.Xml.XmlWriter.Create(System.String, System.Xml.XmlWriterSettings)

      at System.Xml.Linq.XDocument.Save(System.String, System.Xml.Linq.SaveOptions)

      at PodiumControl.WindowMain.PrivateFileCheck()

      at PodiumControl.WindowMain..ctor()


    Exception Info: System.Windows.Markup.XamlParseException

      at System.Windows.Markup.WpfXamlLoader.Load(System.Xaml.XamlReader, System.Xaml.IXamlObjectWriterFactory, Boolean, System.Object, System.Xaml.XamlObjectWriterSettings, System.Uri)

      at System.Windows.Markup.WpfXamlLoader.LoadBaml(System.Xaml.XamlReader, Boolean, System.Object, System.Xaml.Permissions.XamlAccessLevel, System.Uri)

      at System.Windows.Markup.XamlReader.LoadBaml(System.IO.Stream, System.Windows.Markup.ParserContext, System.Object, Boolean)

      at System.Windows.Application.LoadBamlStreamWithSyncInfo(System.IO.Stream, System.Windows.Markup.ParserContext)

      at System.Windows.Application.LoadComponent(System.Uri, Boolean)

      at System.Windows.Application.DoStartup()

      at System.Windows.Application.<.ctor>b__1_0(System.Object)

      at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)

      at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)

      at System.Windows.Threading.DispatcherOperation.InvokeImpl()

      at System.Windows.Threading.DispatcherOperation.InvokeInSecurityContext(System.Object)

      at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

      at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

      at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)

      at MS.Internal.CulturePreservingExecutionContext.Run(MS.Internal.CulturePreservingExecutionContext, System.Threading.ContextCallback, System.Object)

      at System.Windows.Threading.DispatcherOperation.Invoke()

      at System.Windows.Threading.Dispatcher.ProcessQueue()

      at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)

      at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)

      at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)

      at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)

      at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)

      at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)

      at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)

      at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)

      at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)

      at System.Windows.Threading.Dispatcher.PushFrame(System.Windows.Threading.DispatcherFrame)

      at System.Windows.Application.RunDispatcher(System.Object)

      at System.Windows.Application.RunInternal(System.Windows.Window)

      at System.Windows.Application.Run(System.Windows.Window)

      at PodiumControl.App.Main()

  • Thanks. I have forwarded this for further analysis.

  • edited June 3

    Can you please create a new folder named "xml" in the following directory: C:\users\[YOUR USERNAME]\AppData\Local\Fanatec\FanaLab so that afterwards both a "settings" and a "xml" folder are there and then try to start FanaLab again?


  • I created the xml folder (the settings folder already exists) and now Fanalab 1.64.5 started !!

    Thanks, cannot believe it was so simple. Maybe Fanalab should check for this folder at startup, and I don't understand why this was not a problem for the 1.61.3 version.

    In any case, thank you very much, Maurice.

  • Lol new version doesn't even start.

    Thanks. This fixed it. Like i said. Maurice is holding everything together...

  • edited June 3

    Nice!

    Thank you for the Logs and also for your time and efforts adding the xml folder.

    If someone else has the same issue, we now know how to help him. :)

    Will be investigated next week and directly fixed with a new FanaLab version soon then I think.

  • Sorry Maurice

    because when I download fanalab 1.64.5 it crashes in the middle download

    the new driver is Great

  • Please try a different Browser or disable your Anti Virus.

    Just tried on 3 Browsers and the download works fine so something on your PC must block the download somehow.

  • thanks Maurice...FanaFast

  • Marcel PfisterMarcel Pfister Member, Administrator
    edited June 3

    Optional Hotfix for Crash on Startup

    Fanalab 1.64.5 can crash on Startup when the CustomGameConfig.xml is not present in the TEMP folder which is only the case for some people. In this case you can download the additional file below and extract it into your FanaLab installation directory to replace the fanalab.exe.


  • I had the same problem and after creating the folder it successfully started.

    Thanks Maurice

  • Hey, Maurice. Could You share your fanalab profiles?

  • Had them uploaded in the Share Thread but sure, can upload the same post here as well :)


    With todays release of FanaLab 1.64.5 a lot of Bugfixes but also new telemetry features for AMS2 arrived and (of course) I have updated my aMS2 profiles with the new features like DRS and ABS&TC data.

    I also adjusted the RPM values for the Formula Ultimate Gen2 car as they were changed by the latest Game update so the previous values were no longer correct.

    And I also adjusted some RPM values of some ACC cars (including the Porsche 992 Cup) as those were also (quietly) changed in latest Game updates so the old values also didnt matched anymore.

    Newest Pack of profiles attached :)


  • No additional LED colours? Or LED dimming? Any idea if/when this will be implemented? This was discussed a while back, just thought it might have been introduced at the same time as the big Firmware update. Thanks guys.

  • Hi Maurice , first of all thanks again for your work and sharing that with us

    I got a little issue with the Porsche 991 GT3 II , i feel the wheel to responsive , the angle angle of the wheel i mean .

    So i tried to understand , reading everywhere we have to choose 900 angle ingame and inFanalab and let the game do the work to set correct steering wheel for each car

    But in all your Fanalab profiles you set to Auto and ingame 1070 , the correct angle will also be set automaticly by the game ?

  • Yes, the correct angle will also be set by the game.

    Auto = 1080 but I need to use in game 1070 to perfectly match the in game steering wheel with my physical steering wheel. Usually when using SEN Auto you should use in game 1080 but depending on various factors the in game steering wheel can be slightly off so you either have to slightly increase or decrease the value, in my case I have to decrease to 1070. But SEN Auto stil means the game sets everything for you (unfortunately ACC doesnt use Soft Lock though so thats the only thing the game does not set properly).

  • No ETA on this, but its planned.

    More important were Bugfixes for now (and most likely is still as there are still some issues which first need to be fixed before implementing new features).

  • That makes sense. No point in introducing more possible problems before fixing existing ones. I will justy wait patiently. It WILL come. Thanks.

  • Looks like the porsche gt3 display is still freezing up on the new version of fanalab.

  • In which scenario? In which game? Any way to reproduce it?

    I tested the BME a lot in the last days to test the several ITM fixes and in several hours it did not freezed even one time for me...

  • It only happens to me in AMS2, seems very random but usually crashes once, I have to alt tab out of game, shut down fanalab, restart my wheelbase and restart fanalab, it then usually works properly for the rest of the session.

  • Can someone tell me where to place Maurice's profiles for Fanalab. Which folder etc... Thanks

  • edited June 4

    Go to the Game Profile Tab and click on the Import button and select the profiles (mass-Import is possible).

  • Hello Maurice,

    today I installed Fanalab for the first time. In the main menu, my V3 pedals are grayed out and below it says *Not Available (WheelBase)* The pedals are connected to the DD1.

    Any idea why this is please?


    Thanks Heinz

This discussion has been closed.