Fanatec Driver 447 (Public Release Version) (Prev. 445-446) for CSL, CSW and Podium WB (all wheels)

1235717

Comments

  • Only an issue on PC as its a PC Driver/SDK related issue.

  • Varun DesaiVarun Desai Member
    edited September 2022

    Installed 447 last night from 443, and suddenly I've had two big complete PC crashes mid race. No other software/driver installed and it's happened now in TWO different games (AC and ACC). Very weird. Anyone having this? Only fix is to completely turn off PC/hard reset. ALL peripherals freeze + monitors shut off mid race.

    EDIT - Make that 4 big crashes in first two hours of testing after installing 447.

  • What is the exact problem?

    Didn't know about the bug and have been using it all the time and noticed nothing?

    Can confirm 447 fixed CSPv2 bug but I also had 1 moment of complete 'loss' and 'jolts',never had before so will be testing further.....

  • edited September 2022

    F1 22, Race Room and rFactor 2 make use of Auto Setup but when exiting the game, SEN AUTO doesn't get set back to the default of either 900 or 1080 depending on the base. This leads to issues when launching a different game like AC which doesn't use AUTO because the customer and AC will expect 1080 but it's still at a different value previously set by F1, rF2 or RR.

    This is especially noticable when exiting F1 22 where AUTO typically uses a SEN of 360 and when then launching for example iRacing with SEN AUTO then the steering is still 360° so the complete steering range is completely screwed.

  • Ok got it many thanks for the explanation.

    Mostly use RR and DR/2.0 and the profiles from Fanalab

  • Bizarre that his new issue was introduced into the official release stream. The whole point of having a beta stream and an official release stream is that new bugs are kept out of the official versions. Equally strange that you say it was introduced in 443 but wasn't mentioned in the release notes of that version or the four that followed it. Fanatec still need to do some work on their testing and software quality control. Buggy betas are understandable, buggy official releases are not.

  • edited September 2022

    It's not a new bug. I never said it was introduced with 443. Please carefully read my messages without interpreting your own things.

    Was also in the older official driver releases and has nothing to do with a beta and a release Branch.

    Every Software in the World, no matter if beta or release, is Bug free. That's just impossible.

    There are quite some more internally known issues on the list which are not mentioned. Almost no company in the world lists every single known issue.

    So of course neither an official release nor a beta will ever be completely Bug free.

    Heck, I dont know if you know Corsair iCUE?! Its one of the worst softwares in the world which I have to use for all my Corsair stuff to function properly but its so bugged and with every official release version new issues are introduced. Software is just very complex and at some point you have to release something with known issues, it pretty normal in the industry.

  • You mentioned this being bugged also in 443 which I interpreted as meaning it was introduced then. Your message wasn't clear that it was present earlier. If this issue was mentioned in the release notes it would mitigate any confusion - I'm not as familiar with these bugs as you clearly are.


    Thanks for the software development lessons, it's been my career for over 20 years! :-)

  • Does this happen only when playing racing games on Fanatec hardware? It's highly unlikely this is caused by a properly installed driver update. Driver related crash would rather throw a BSOD at you with a trace to investigate. A complete black screen freeze would rather indicate a CPU/ram/Mobo/PSU/voltage issue. Have you overclocked or undervolted any component recently by any chance? GPU issue would rather crash the game to desktop and not freeze the PC totally.

    However, IIRCC I think someone mentioned a similar issue in some of the previous versions topic and the solution was to completely uninstall Fanatec stuff, reset and install again but properly - meaning without anti virus protection for that time and without USB hubs. But still I would be surprised if this was a input device driver problem and not a hardware issue. Looks more like not enough voltage somewhere to me.

  • Removing and reattaching the shaft also did not solve the problem, I have also tried using different USB ports on the motherboard. I guess it's time for Fanatec support.

  • I am using dd2 and fanatec Porsche 918 RSR

    Sometimes the wheel is not recognized when the base is turned on.

    The wheel icon on the screen is not activated and does not work

    It happened since driver 442 and it also happens with 444

    Yesterday I confirmed that it also happens with driver 447.

    When the base is turned off and on, it is recognized and operated normally.

    The video itself is not attached as a file, so it is attached as a compressed file.

    Please take a closer look at the display handle icon

    I disconnected the wheelbase and the wheel and tried to connect them again, but the symptom appeared even after that.


  • Timo TuominenTimo Tuominen Member
    edited September 2022

    Hey all. Currently running Driver 434, and wanted to uppgrade to newest, but noticed that there is problem with the SEN AUTO settings. Is it only on some specific games? Because now i use auto sens with Dirt rally 2.0 and iracing. What yours thoughts, should i still update or wait for the fix?

    -Timo

    EDIT: CSL DD

  • Hi, I'm experiencing the 100% fan issue with the dd1 base not being recognized in conjunction with the McClaren GT3 V2 wheel. Can you please advise on steps to resolve? I've uninstalled all drivers, and am unsure where to go from here. Thanks

  • Marcel PfisterMarcel Pfister Member, Administrator

    I've responded to your personal message with a guide on how to bring it back to a functional state. Let me know if you have further questions.

  • Marcel PfisterMarcel Pfister Member, Administrator

    The two games you mention don't use SEN AUTO (Sending a command to the base to set a specific SEN value) which means you won't notice an issue in those games. For Dirt and iRacing you can also just use SEN on 1080 if you want to, this avoids any other game launched before potentially changing SEN AUTO and not changing it back on exit of the game. For example it could happen that F1 22 sets SEN AUTO to 360 but not back when exiting the game, then you would have 360 in other games launched afterwards.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Thanks, I've added it including a tip for a workaround.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Sorry to hear that, so far haven't heard this. Can you still go back to the driver which worked fine for you before and compare?

  • Marcel PfisterMarcel Pfister Member, Administrator
    edited September 2022


    Does it also happen during use or only sometimes when booting? Does it maybe make a difference in which angle the wheel is positioned before booting?

    When this happens, is the wheel shown in the driver? Is the tuning menu working?

    What happens after re-attaching or maybe wiggling the wheel, to make sure its not a loose contact or something.

    The new driver has an integrated downgrade feature in the top right of the Firmware Manager, you could use it to check if it makes a difference when going back to earlier firmware versions. That way you can try it more easily and safely without the need to install an older driver.

  • Marcel PfisterMarcel Pfister Member, Administrator

    When there is no FFB, what does the P DD base display show in the top right, is there a steering wheel icon shown or not?

  • Does not occur while in use

    Occurs when the computer is on and booting the base

    I tried changing the angle of the wheel a few times before booting, but it didn't happen

    If the wheel is not recognized and does not work, I could not check whether the wheel was visible or the tuning menu was working because the base was immediately turned off and on.

    It occurred even after disconnecting the base and the wheel and reconnecting them.

    I use it in combination with bolts


    It didn't happen with older firmware

    It occurred after updating the firmware in driver 442, and I experienced that it occurred up to driver 447.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Thank you for the additional info. When it happens again it would be interesting if the driver will show it or not.

    It sounds similar to the issue Jopseph Figueroa is having which is why I asked him to check if the wheel icon on the base was visible or not when he has his issue.

  • Is this an issue specific to certain wheelbases? I haven't noticed anything detrimental using AUTO with a DD2 in Automobilista 2 (447/166).

  • edited September 2022

    Its (now) listed in the known issues. Only when driving certain games (F1 22, R3E, rF2) and afterwards any other games which dont use SEN AUTO are affected, but all bases, yes.

  • edited September 2022

    I am using the CSL DD with the 447 and updated firmware. The following happens to me...


    I have seen that more people are having it in AC or ACC. I have reverted to 339 which is the last one that worked for me (and installing a beta 1.1.5.4 firmware to avoid jolts) and it keeps happening...

    I have disconnected the QR and I have reconnected it but that is perfect, it has not moved, I have disabled USB power saving. what can I do? I have a year of continuous problems.

    It does not detect the movement or the buttons for 2 seconds and the jolts thing happened to me before, supposedly corrected in these new versions

    I have sent to Germany 2 times to check the wheell base and I still have problems, it is incredible

    GP2 ENGINE

  • edited September 2022

    That does not look like any possible firmware issue but definitely more like a serious hardware issue. You should contact the support.

  • it happened again

    The driver does not recognize the wheel

    It is possible to change the tuning menu with only the base recognized.

    Attach a screenshot


  • Thanks, just saw that you had actually already answered this earlier in the thread.

    Would you recommend to change the Fanalab profiles that use AUTO until then? Or could I for example drive F1 22 with AUTO, and then restart my PC and/or DD2 to avoid this issue?

  • i downloaded this driver for my DD1 After reading forza patch notes that the game will not crash after 440 driver. I absolutely love 447 thank you for creating this software it feels great!

This discussion has been closed.