Fanatec Driver 455 Release for CSL, CS and Podium (all wheels)



  • Eric BeaulieuEric Beaulieu Member
    edited January 3


    CSL Elite Wheel base SN PV31000816

    Motor FW: 22

    PS5 software: 23.02-

    Gran Turismo 7 version: 01.410.345b9756A

    No force feedback in Gran Turismo after updating to the new FW 693. Downgrading to FW 692 fixed the issue. The game itself was seeing all other steering and pedals inputs.

  • Come on Fanatec i spent over £1000 on something that hasnt worked out of the box! how can i get my CS DD working with Mclaren gt3 v2. just says wheel firmware 0. its annoying that CS DD was shipped and doesnt even have its own manual!

  • I have tried it on three different computers. I have tried another version of the Fanatec Driver, and I have tried downgrading the base Wheel version to previous ones, both with the Fanatec Driver 455, as well as with the 454 and the 452. I think I have tried everything.

  • Does anyone know why my DD1 is getting this error when I first turn on the base? I am running all the latest driver and firmware. Thank you,

  • Allan LehtlaAllan Lehtla Member
    edited January 4

    hmm, i think you should downgrade to the 2021 firmware one instead and then after that to the 455, like i todo, honestly tell i not know what is happening at they firmware update, but something is not right at there

    but if even that not helps then yours can be broken

  • 2021 firmware wont help him.

    As I said several times already his WQR hardware Module is broken.

    Nothing a Firmware can fix!

  • Allan LehtlaAllan Lehtla Member
    edited January 4


    there is issue tho, if i downgrade from 455 to 2021 one , it keeps the WQR v7 and it not downgrade that

    i todo that because i installed 451. this xbox missing started piss me off

    by default it means if user even want fix, he cant as software not even try that for WQR

  • Hi all ive tried updating to the newest 455 driver as of today when writing this and my firmware for csl dd 8nm base and formula rim also update but for some really annoying reason which am annoyed with not had an issue like this since having these couple years ago when i got them but with in this newest update my bundle is made for xbox ready which i mostly play on for league racing f1 and for some reason now the xbox green button mode has gone it basically switches between normal pc mode when plugged into pc or goes to pc compat mode tried everything checking the cables make sure there tight checked the screws too on the qr1 i have and checked the wheel is tightened when locked into place just dont get what ive done wrong seriously frustrated with is as its made me sit out my wor race i had very frustrated dont know what to do

  • MadDog-ICMadDog-IC Member
    edited January 5

    Post your complete Fanatec Logs so someone might be able to help you. Snap shot picture of Fanatec driver config page, with components showing FW versions, etc would be useful also.

  • This can happen on every 20th base start or so.

    Nothing to worry about, just close it.

  • Hello, everyone,

    Yesterday, Fanatec wrote to me again, giving me 8 points of things I could do to solve the problem, but I already tried all of those things and the problem is not solved.

    I sent them again what Maurice is telling me, to see if we can go faster and if I have to send the base as soon as possible. I asked them please, as soon as possible, and that everything they told me had already been proven.

  • We are going to try to make one last attempt, to see if this is solved or not. I can try it tonight.

    Now I have Fanatec Driver 455 installed and the Wheel Base, the engine and the WQR updated with the latest versions and there is no steering wheel.

    What steps must I take?

    Uninstall 455, which one do I install? Or if I lower the base version to 2021 before, or what steps do I have to do with both the Fanatec Driver and the base Firmware.

  • Allan LehtlaAllan Lehtla Member
    edited January 5

    can you show picture from your firmware? im not sure what you say atm

    if base not detect steering wheel but you have WQR v7 at there, you may have some other issue happening

  • Yes, of course, this it a video of what we have.

    I cant send a Video, a send a photo

    This is what i have Now

  • ok that is something else what is happening for you atm. because you to have installed already wqr 7

  • Allan LehtlaAllan Lehtla Member
    edited January 5

    maybe some controller driver is disabled at in device manager, can you check that out?

    to you happen have more than one steering wheel for look if its steering wheel self?

  • Any idea how long before podium button rally module sequential issue will be fixed? Just a bit annoying to have a £650 wheel bundle that I’ve had for two weeks and can’t use :(

  • edited January 5

    No ETA yet. Maybe this month, maybe later. Cant say for sure as every required dev is on (well deserved) vacation this week, work is only getting started next week again.

  • I’m glad they are getting rest but surely you can understand why likes of myself is frustrated at spending so much on a product that’s now just sitting and can’t be used until this is fixed

  • I can totally understand that, yes, and I am sorry for everyone affected by this issue which is caused by no real betatest had happened for this product before launch so it launched with quite some issues which now need to be fixed over the next months.

  • I'm having issues with my drivers. I am using the Clubsport shifter and the handbrake from fanatec, my wheel and pedals are the logitech g920. The error reads

    "Access violation at address 0x80063e38 in module 'FAWForceFeedbackDrv64.dll' + 0x63e38.


    I deleted everything in programfiles/fanatec and then redownloaded driver 455 yet I still get this error. I think this issue is causing other games that I want to play to crash on startup when I try to use the fanatec gear. When I unplug my shifter the games will run fine.

  • edited January 5

    That is no error but a totally normal message.

    You dont have a Force Feedback device from Fanatec, so simply ignore these messages, they mean nothing and are not related to the issue that your games crash.

  • I get that I don't have a FFB device, I just don't understand why I'm not able to load games when I have the club sport shifter plugged in. Do I have a bricked shifter? Or are there other issues that may be causing Dirt 2,, and Assetto Corsa Competitzione to crash back to desktop on startup? I'm just lost and have been trying to figure out what is causing the issue.

  • I have no idea, I only know those error messages are no issue but normal, even for people who do have Fanatec FFB devices.

    I assume you use two ClubSport USB Adapter?

    Maybe try a different USB port.

  • Hi lately I have an issue with my DD2, hope somebody can help me.

    I posted this in hardware section but not sure if this could be related to the driver, so I post it here also.

    I have the DD2, last driver (455) and firmware updated, I am using a formula V2.5 wheel.

    I have it limited to 15Nm (in iRacing having it to full 25Nm is a dangerous game in case you crash...).

    For first time I run endurance races in iRacing this last weeks, I run two races of 160 and 180 minutes, so 3 and almost 3hrs of driving. The issue is aprox after 1.5 or 2hrs (not sure of the exact time, but more than 1.5hrs for sure), suddenly I loose almost all the FFB for just a second, I think I am not loosing all the FFB completly but it decrease a lot, the wheel looses almost all resistance, but as said it is only 1 second, inmediately I got proper FFB again (fortunatelly in both cases I was in a straight and did not crash...). After this "panic" second everything is OK till I end the race. It happened in both long race, not sure of the time stamp but for sure in both cases after more than 1.5hrs. When happened I was not able to check in the base screen, so do not know if there is some message there.

    So now I am not sure at all to try again as this could be a lottery if it happens in a corner and I crash after more than 2hrs of driving.

    info, as I thougth maybe is a temperature issue, as said the base is limited to 60% of the Nm (15) and also the room is not hot at all, lately here in Madrid is pretty cold.

    Any idea what could happen?, is there a way to check a log or similar to figure out?

  • Hallo zusammen,

    hab mir das GT DD Pro (5Nm) Set gekauft. Ich kann die WB updaten, das GT-Lenkrad wird erkannt, aber ich kann es nicht updaten (Treiber 439 - 455 kein Update möglich). Es sieht danach aus, als könnte der Updater keine Verbindung zum Lenkrad aufbauen.

    Da ich schon viel probiert habe, jedoch erfolglos blieb, kam mir folgende Frage auf...

    Kann man das Lenkrad inklusive abgebautem QR , an einem USB-C Port am Laptop updaten, direkt ohne WB dazwischen?? Hat da vielleicht schon jemand Erfahrungen gesammelt??

    Versuche nun seit 2 Wochen das Problem zu lösen und würde mich über eine hilfreiche Antwort sehr freuen! Bei Bedarf, kann ich auch noch Informationen zu Treibern und Co geben...

    Danke euch schon mal!

  • Downgraded back to 454. After doing a firmware update to 455. The GT DD Pro wheel base wont activate the XBox licence chip on CS SW Formula V2X but works fine on CS UHX V2. I will have to drive around in a game with the CS UHX V2 on the xbox and try swapping out to the CS SW Formula rim and sometimes after a few tries it works. I looked at the change log for both 454 and 455 and the only thing that changed that applies to my setup is base firmware from in packet 454 vs in packet 455.

    The issue was only noticed when using the Xbox Series X Console. On PS5 there is no issue.

    After downgrading the base firmware to all is working as expected. I'll wait for the next firmware update in 456

  • Hi @Maurice, one more hint on this issue: After the error occured last time in AMS2 I played Raceroom without turning the wheel off or doing anything else and was surprised, that the LEDs and the display continued to work and the issue was not there anymore. After re-playing AMS2 after 20 minutes the problems started to re-occur.

    Maybe this helps you for your investigations :-)

  • Mark GleesonMark Gleeson Member
    edited January 7


    I recently updated the firmware of my CSL DD wheelbase, formula 2.5x wheel, and clubsport v3 pedals. I use my laptop to upgrade, but then connect my Fanatec equipment back to my Xbox series x for sim racing.

    I upgraded using the latest 455 drivers. The firmware update worked flawlessly, however my wheel base will no longer enter Xbox mode with the formula v2.5x wheel connected (I can switch between PC and PC compatibility mode only).

    If I swap to my WRC wheel the wheel base immediately switches to Xbox mode and plays fine. If I then keep everything connected and swap wheels back to my formula v2.5x it will sometimes stay in Xbox mode and the formula wheel works, but as soon as I power down and back on again the problem is back.

    Everything worked perfectly prior to the firmware upgrade.

    I’ve logged a ticket with Fanatec support but any help in the meantime would be appreciated.

This discussion has been closed.