Fanatec Driver 457 Release Candidate for CSL, ClubSport and Podium (all wheels)

13468936

Comments

  • Jordan LABBEJordan LABBE Member
    edited April 27

    One day with the 457 and all good for me so far on PC.

    Need more time to test on ps5 but i did one hour or so and it went well. I mixed the firmware before to get that fixed and was a bit scared of updating with 457 but it seems that my dd+ f1 is back to life with a great feed back from the base.


    Only issue i have is that coil noise but its just annoying. No impact on the driving and i dont wanna get into a warrant procedure as i assume it could take a lot of time...

    Gg team.

  • At least I've tried to connect with the PS5 USB-C cable from the Base to the front port ( I m with slim PS5 with USB-C front port )

    The rear USB-A was really hot maybe there is an impact. Played one hour like that without à problem, I ll see if it continue to work well.

    I ll keep you update.

  • Alan AxonAlan Axon Member
    edited April 27

    @Gökhan Ogul thanks. I have Raceroom and LMU (although the latter is likely to be the same being so closely related) so I will try Raceroom. I did completely remove the Player JSON and Controller JSON (to allow a rebuild of both) earlier in the week as after the longer drop out it wouldn't recognise my wheel at all. As it didn't resolve that issue I pasted it back in so will try again with a whole player folder renewal.

  • ScSc Member

    CS DD+

    CS RS Wheel

    PS5 / GT7

    installed 457 yesterday.

    Flashing Base and WQR went through smoothly. During this process I could hear a significant noise (water flowing through a pipe). However the noise disappeared after completing and restarting the base.

    Played about 1 hour and base is working flawless but it also did with 455 and 456.

  • Guys sorry... I strongly advise everyone to carefully check all connections, especially the power supply. I also tried using the front USB C of the PS5 and I still noticed a slight improvement. When I still had the problem of the power supply Not well connected. Also try reflashing the firmware, because they noticed an improvement. I recommend everyone to check everything from A to Z.

  • Another thing... very important! we need to create a discussion (setting CS DD PRO on on gt7 acc etc, to discuss the various settings to use!! Because here on the forum there is nothing for our base!!

  • Hey, the xbox mode problem not solved completely. Its the same problem like with 456. My McLaren GT and Universal Hub v2 go into xbox mode, the formula 2.5x not. It change only between pc and pc compatibility mode.

    I updated every firmware. When i go back to 455, the formula 2.5x works with xbox mode, but there is the problem with the funkyswitch (every move activate the push A button)

  • Gökhan OgulGökhan Ogul Member
    edited April 27

    @Alan Axon An be sure that you change to steam controller setting for rFactor2:

    1. Make sure RF2 isn’t running
    2. Open Steam
    3. Right click on RF2 go to properties
    4. Click on Controller
    5. Then select “Disable Steam inputs” in the drop down menu.

    I hope this and deleting player data helps you fix the problem. rf2 works fine for me with same McLaren GT3 Wheel on CS DD without any disconnection.

  • In the case of DD+ and the Podium Porsche 911 GT3 steering wheel - the square and x buttons in BME in GT7 have the same effect. They are double! The same error was in 456 and now in 457. This problem does not occur with other steering wheels. Previously, this error did not occur in GT DD PRO. After testing the DD+ and 457 , I don't see any other problems.

  • The BME Button bug was not a part of this driver. As Maurice said will this be fixed in a future driver.

  • Markus TMarkus T Member
    edited April 27

    I also just had the issue that a few people reported where the wheel is now crashing but coming back alive a few seconds later.

    I'll roll back to 455 again as I need something stable for the GTWS races in GT7.

    EDIT: Got in an update loop when trying to flash the FW from 455 onto the base... Guess I'll stick to 457 after all

    EDIT 2: Just to clarify: The issue with the crashes is a bit different than before. With 455 and 456 it's pretty clear as it's the QR crashing as button presses are no longer recognized, but pedal input and wheel rotation is.

    This is different. When it crashes, everything is gone and frozen in place until it comes back

  • @Marcel Pfister

    @Maurice Böschen

    I just wanted to give a quick update on my DD + issue.

    I think I figured out what is causing the disconnect issue.

    It's the Shaft.

    I turn on the Wheelbase.

    Everything else is off.

    I start turning the Wheel to either left or right.

    As soon as I reach approximately 90 degrees of rotation, I feel the resistance drops off and the Wheel Display shows the F.

    After a few seconds it reconnects and I can feel the rotation resistance again.


    So no matter if I turn it to the left or to the right WITH an attached Wheel, it will disconnect.


    On the other hand though, if I detach the Wheel and turn the Shaft itself, it NEVER disconnects or drops the resistance.


    So it's definitely something to do with the pins within the QR Shaft causing the disconnect issue.


    The pins are not bend or broken.

    Everything is firm.


    Anything I can do?

  • Gökhan OgulGökhan Ogul Member
    edited April 27

    @David Livaic Can you test this scenario? Power On the base without attached wheel (attach after booting up) then test it. And tested what happens if you disconnect your usb cable? that would be important to know.

  • I just did that.

    No USB connected.

    No Wheel attached.

    I start the Wheelbase.

    After the Shaft Rotation/calibration , I attach the Wheel.

    The Screen and rotary buttons light up.

    Display shows all info about firmware and no USB connected.


    I slightly start to turn the wheel a few degrees and it looses connection/friction/resistance and the lights go out.

    After 2-5 seconds the wheel display will light up again and rotary encoders.


    I start turning the Wheel just a little bit and again the same as before happens.

  • @David Livaic

    Ok. Thanks, then you should now test it with the previous driver 455 QR firmware (not the base). If this also happens with the previous WQR firmware (from driver 455), your WQR modul may be broken and you need to contact the support. Better were to have a second wheel for test.

  • But is this 457 problem free with CSL DD's, it seems that mostly CS's owners has those problems.

  • Gökhan OgulGökhan Ogul Member
    edited April 27

    CSL DDs are not affected and on CS DDs this is a new case in a few users, specielly on PS5. Because this we have to find out what causing the error, hardware, firmware or user fault such as robertinos case.  This can be solved only step by step tests and it helps for developers to find out the error.

  • I am not having the disconnect problem, but I am wondering if the CS DD wheels need a powered usb 3 hub like a lot of other peripherals that draw too much power?

  • I'm unable to roll back to 455 for the wheel base. The flashing runs through, but the wheel is then stuck in update mode and it's impossible to get it out of there. The only thing I can do then is to uninstall 455, reinstall 457 and let it run that again. Then it's back alive.

    Downgraded QR to 455 now, hoping that helps

  • Same as Markus, could not flash 455 base FW. Just gets stuck in update mode. If I would know 457 locks me in, wouldn't upgrade...

    If I get time will try 455 install but just take fw file. And then install again 457 and use fw file I took from 455. Maybe older flash tool is not usable after update to 457.

  • DD Extreme:

    The fw update went well. No issues for like 4 or 5 hours. Then, all of a sudden, the wheel rim lost all its buttons, shifters, etc., like it was before. The only difference this time is that 1) it only happened after a couple of hours versus kinda like once every hour, and 2) it recovered itself within a few seconds without me having to do anything. PS5/GT7

  • Hello!

    Axle base model: Cs dd+

    steering wheel: gt extreme

    Driver version: 457

    wheel base firmware: 2.1.0.3

    Steering Wheel firmware: 1.0.7.0

    Engine: 1.0.2

    quick release firmware 1.1.0.1


    1.

    About 8 times out of 10 activations, the brake pedal works from 20%, 2 times there is no problem with it (csl pedals not load cell, tested on PC). With 455 it was consistently bad. I asked for an rma on the pedal, got a new set of pedals, but it didn't solve the problem. I was hoping the 457 driver would fix it. Is it possible that this is a hardware problem with dd+? I only use the factory cables, connected on the back of the ps5. I checked everything, the connections are fine everywhere. With csl elite base it works perfectly with p1 handlebars and also with dd pro!


    2.

    FFB test Strong humming, strange sound when testing Road Texture and Curb Vibration. Almost nothing can be felt on the steering wheel, but it starts to make a humming sound relatively loudly, not as melodious as with Engine, shifting, Rev-limit or Pure froce effects. Is this buzzing strange sound normal?

  • A quick update on my Wheelbase issue.

    It definitely is a hardware defect.

    I tested it in the Fanatec Driver Menu on my laptop.

    It clearly shows the Wheel disconnect for a glimpse and immediately reconnect it again.


    It's exactly the same as in this video

    Like I said it's a very short disconnect and immediate reconnect.


    https://www.reddit.com/r/Fanatec/comments/15qz1hl/need_help_troubleshooting_csl_dd8_and_mclaren_gt3/?utm_source=share&utm_medium=mweb3x&utm_name=mweb3xcss&utm_term=1&utm_content=share_button

  • @David Livaic

    it does it all the time? or randomly?

  • @Gökhan Ogul. I tried both Raceroom and LMU and both seemed fine. I had the generic steam controller disabled and removed my player folder but I still had issues. I tried USB 3.2, 3.0 and 2.0 and although slight variations I still had issues. I decided that the final thing to do was a complete game removal and reinstall. So far so good and with the same settings now on the new install my FFB feels a lot stronger. Not sure what it was but hopefully it is gone for good. Thanks for your help.

  • Gökhan OgulGökhan Ogul Member
    edited April 27

    @Alan Axon: I'm glad when I could help you and that another problem that was solved. I hope it works now for you!

    @David Livaic: The CSL DD has a shaft that can slide forward and cause these connection failures. The CS DD has connector cables without USB-C and the connection with modul works wireless. When you have the same problem with previous QR Firmware too, as said your WQR Modul is broken or connector problem. Seems you have to contact the support.

  • Tae YooTae Yoo Member

    @David Livaic: I'm not sure if you've already tried, if you have another wheel, check to see if failure follows. Just to rule out possibility.

  • Yes I have tried it again with QR Firmware from Driver 455.

    Same result.

    I then again reinstalled Driver 457 and updated back again to the 1.1.0.1 QR Firmware.

    And again same result.

    And of course I tried it with both of my wheels.

    Everytime with the same results.

    Reproducable disconnects.


    Whats interesting though is the fact that it worked absolutely flawless for 6 weeks.

    It suddenly started with a disconnect now and then.

    And it quickly developed into this huge massive mess.

    BTW, how long does it take the support employee to reply to my support request?

    I described the issue extremely detailed and sent them a few Videos.

    Will they sent me an email with a return label?

    I have no idea.

    Maybe someone can clarify it.

    Thanks

  • Gökhan OgulGökhan Ogul Member
    edited April 27

    @Dávid Vörös what you mean with it begins after start with 20%? The csl pedals without loading cell don't calibrate byself after start. You need to press and release it, then it will be automatically calibrated internally by driver, and this every time after power on. If it always at 20% after press and release, you can adjust it yourself with a workaround. Open the Pedal backside cover, put out the gear block, then you have to turn the small gear block 1-2 teeth and put it back in, keep trying until it starts at 0% and you can press 100%.

Sign In or Register to comment.