DD1 recognises CSP V3 pedals but PC doesnt

Hi Guys,

I have just bought the Clubsport V3 pedals and connected them via RJ12 to my DD1. The DD1 recognises them. I can see it on the LED screen but the PC doesn't see them. If I connect using USB then it recognises them OK. FYI. Pedals are firmware 335 which to my knowledge is up to date.

Comments

  • Are you using the supplied RJ12 that came with the DD1? Also have you tried using a different USB Input on the PC?
  • Yes I have tried different USB ports and I have tried the cable that came with the pedals and the cable that came with the base
  • edited July 2019
    Are they showing up in the Fanatec driver window? Also check the connection underneath the pedal plate to make sure it is fully connected. Other option would be to update to driver package v340 listed on page 1 of the blog and see if it helps.

    If that doesn't work my suggestion would be to contact support.
  • Hi Joseph,

    I logged a ticket with support and after some basic reseating tests they gave me the v340 driver you mentioned. This resolved the issue.

    Thanks for your help
  • Great to hear all is working Darryn.
Sign In or Register to comment.