FanaLab 1.23 beta Download - Post your Feedback here

1568101117

Comments

  • just got my dd1 pbme porsche and no itm only displays gear number at shift

  • ITM does not show in fanalab

  • Because v1.23 is not supporting ITM yet. You need v1.24 from the BME software package 1.2 and click on the ITM registry file to activate ITM.

  • dears,

    since i read often 1.24 i'm asking where is the 1.24 ?

    and mainly i have csw 2.5. do i need 1.24 fanalab?

    thx a lot

  • What's the ETA on AM2 Profile for fanalab S/W, TY.

  • The 1.24 is part of the driver package for the BME, you can find it in the software package. But as far as I understood it is basically the same as 1.23 just adds the BMW functionality. So if you´re running the CSW 2.5 you should be fine with 1.23

  • Hello,

    What can Fanalab do that the driver can't? I run AC fine without Fanalab running.


    Thank you,


    Serge

  • A lot. There are YouTube videos available. Fanalab can control telemetry based vibrations, additional dynamic FFB effects, led control, thousands of game profiles which also can be loaded automatically when the game starts etc etc etc

  • Thanks for the response but im new to the whole thing so please excuse me . So in properties DD1 i open go to update page and my firmware for the BME says 9 ? I can change rev led color in fanalab but doesnt go to BME still yellow. Thank you for any input.

  • Sorry i did get the color to change on led revs. But the only telemetry i can seem to get is gear shift.

  • DD1, driver 352. Fanalab 1.23, Windows 10 PRO pc

    Fanalab Crashes when clicking the LED tab when DD1 is connected. Does not matter if a game is running or not. Rest works as expected. If no DD! is connected I can click the LED tab without issue, just gives notice steering weel not connected.

  • how do I download fanalabs, I've looked all over but can't seem to find it

  • A link is available on the wheel base product pages.

    But to make it short, it's available here in the forum! In this thread! On page 1! In the first post! ;)

  • edited March 7

    Installed a windows update and now fanalabs is not detecting any devices, although it is showing up in the Fanatec Property Settings. I will try to revert the Windows change to see if that fixes the issue, so beware of updating Windows.

    The windows update was the Version 1909 for Windows 10.

  • After any of the big windows updates you have to uninstall and reinstall the Fanatec driver. This will fix your issue

  • Will the CSL WB 1.1 ever be fully supported by Fanalab? Really don't get it why the + version is already supported as the base is the same (only the PS4 license right?).

  • The Base is not the same, the + Base with PS4 compatibility is still the more advanced wheel base.

  • Ok tnx! Then I hope it will be supported by Fanalab...if they will not fully support it in the future it's nice to know. Then I don't have to look a few times a week in this forum ;).

  • Does fanalab work with v2.5

  • edited March 11

    Hey everybody.

    Two things:

    A) Issue Report

    Steering Angle mismatch in iRacing, when using Game Profile with DD2 

     Details: 

    When enabling and loading a Game Profile for iRacing within LABs, the steering Angle sliders highest value (below auto) will be 1080 degrees

    But the wheelbase claims to be set to 2350° instead at that point. Even setting 1080 from Labs, does not change the Wheel Bases value. 

    When reducing the angle from the wheels tuning menu, the slider in Labs decreases accordingly – but is out of sync by around 1300 degrees. 

    When trying to reduce the angle to 1080 from the wheels menu, Lab bottoms out at 600° and bounces back to auto. When this happens, the wheelbase gets reset to 2350°. 

    When deleting or disabling the Game Profile, everyting works as expected. Al

    Reproduction: 

    Setup and Load a Game Profile for iRacing within FanaLabs. Start the Sim. 

    Look at the virtual Wheel in the options Menu (90° Whell turning results in ~45° in Sim) 

     Tested: 

    • Reseted Setup from wheel (1) 
    • Reseted WheelSetup in Fanalabs 
    • Deleted and reconfigured iRacing Profile 
    • Disabled iRacing Profile 

    Workarounds 

    • Do not load iRacing Profile in Labs 
    • Set Angle manual in Fanatec Wheel Properties AFTER loading the sim 

     Environment: 

    • Win 10 1909
    • FanaLabs 1.23 
    • Driver 356 Beta (did exist in 352 too)
    • DD2 Base 
    • Base FW  as per 356 Driver
    • IRacing (as of 10 March 2020)

    Any Ideas or Help here?

    B) general question regarding iRacing/LABs

    Is there any plan yet for a LABs update, since iRacing announced support for Pedal/Wheel Rumble with the latest updates of S2-2020?

    Source: https://members.iracing.com/jforum/posts/list/3700348.page

    Peripherals

    -Support has been added for vibrating pager motors in Fanatec wheel rims and pedals when your car tires lose grip.

    -You can turn off the motor in the wheel by setting the value of joyEnableVibrateWheelWithPedal = 0 in the [Force Feedback] section of the app.ini file.[...]

    [edit] copied wrong driver version -.-

  • New FanaLab version is coming soon which hopefully fixes your sensitivity issue. However, iRacing did NOT opened the vibration for external programs, only for their native support so the vibration wont be coming to FanaLab until iRacing finally really opens their code doors so that external programs can use this telemetry info.

  • Well that was quick. Thanks :)

    I'll retest the Issue and report back, once the update is available.

    Regarding Code doors, yeah very likely, since people will most probably abuse this particular feature for performance reasons. Anyway, good to know, and thanks again. :)

  • I am using a CSW V2.5

    Checked my drivers etc before loading this and noticed that I am running driver 328, wheelbase firmware 628, wheelbase motor firmware 18 and clubsport V3 firmware 1.30. I believe this to all be the latest i can get as clicking update in the wheel properties software states that i have the latest? but noted that driver 352 was required.

    Any help much appreciated

  • NEVER use the update settings in the driver to check for a newer version available. The driver is NOT smart, it has no ethernet connection, it wont and cant see if there is a newer driver or firmware version available online. All it can do is looking if the wheel base firmware which is included in the driver is installed on the wheel base (or a newer one). But it does not look online if a newer version is available, which is the case for you since almost a year now.^^ Its available here in the Beta section in the forum.

  • Thank you Maurice

    I have now loaded driver 356.

    Wheelbase firmware has updated to 669 but if i try to update wheelse motor firmware (still 018) the updater appears to crash - the power rings on the wheelbase flash red in a circula\r motion and the game controller window stops responding? Also whenever I open up the game controller window it tells me that the firmware is out of date - I saw this was a repoerted fault somewhere but clicking no and then chaging screens and going back to the function test screen still pops up the message?

  • edited March 12

    Maurice, do you know if the CSL WB 1.1 will be (fully) supported in the near future? Or will it never? It's nice to know because I still can swap the base to a + version (still want to keep the 1.1 but if it will not be supported I can think twice about the swap).

  • Full support can't be guaranteed to happen yet, we will try to add it at some point but have to see if it can get squeezed in without breaking existing functionality with games for example.

  • Hehe ok (tnx!), I just want some SEN (rotation) settings ;)

Sign In or Register to comment.