Wheel input stutter/lag - PC

I recently purchased a CSL Elite PS4 from a good friend.

Wheel was working perfectly on friends setup.

Set it up on my PC and the steering input is pausing in both in games (iracing/kart kraft) and when looking at the wheel config via game controller "Fanatec Wheel Properties", Function test tab.

If I continuously turn the wheel, you can see the steering wheel slider move in the wheel properties/game, but even though the steering wheel is still turning, the bar will stop moving for a second, and then jump to catch up with where the physical wheel is. The wheel stays powered on and the led's and display remain active.

Same behaviour happens in Game.

Wheel base driver installed is v402. Firmware is 684.

Video attached to demonstrate: https://vimeo.com/540698127

I have established this is not a hardware issue; the wheel works on my friend's PC that I bought the wheel from and I also tried the wheel on my wifes PC and it works without issue, therefore eliminating hardware and cable issues.

The things I have tried on my PC to resolve the issue include:

Formatted hard drive and fresh windows install with just fanatec driver 402 installed.

Full windows update including optional updates.

Bios update

Tried all usb ports 

USB power saving disabled

I have also tried using driver (and associated firmware) 381 but to no avail.

Installed diview and the issue presents in there too.

Run ccleaner and checked for registry errors

I have attached a screenshot of the pc's details inc motherboard etc.

My wife has refused to swap PC's so any help greatly appreciated as I currently have an expensive paper weight!


  • First thing that I would check is the chipset drivers from your pc’s motherboard.

  • I have downloaded the latest chipset drivers from the Asus website but the problem sadly remains

  • So I didn't get to the bottom of what was causing the issue, but managed to sort a work around by installing a £12 PCI usb card!!

Sign In or Register to comment.