CSL Elite Wheelbase + with Clubsport Formula V2 not working!


I recently bought the CSL Elite Wheelbase + (PS4) second hand, and both the Clubsport Formula V2 and CSL Pedals from the Fanatec website to go along with it, for the PS4 console. I was unaware that you had to update the firmware, and met with issues as a result. I then updated the firmware for the wheelbase motor, the wheelbase and the steering wheel with what seemed to be no problems. Until I got into a race on F1 2021 PS4, and 10 seconds in the wheel went into XBOX mode automatically and the force feedback was removed from the wheel. This has happened repeatedly. This seems to happen once I move the wheel around 70-110 degrees left or right. The LED's also lose functionality here as well. It is also important to note that when putting in the steering wheel, I have to adjust the quick release forwards and backwards to find a specific point to where the wheel operates. Here is what I have tried thus far:

  • Tightening the screws inside the quick release of the steering wheel
  • Ensuring all the cords are in properly
  • Repairing/Reinstalling the Fanatac Drivers
  • Reinstalling the Firmware updates, manually
  • Installing latest Fanalab software
  • Trying different USB port
  • Trying different Laptop

Nothing has worked.

Thanks in advance.


Sign In or Register to comment.