CSL DD (No Fanatec Device Found!)

Running a CLS DD, WC2 Rally Wheel, and Club Sport Pedals. Windows 10, Fanatec PC Driver 434. Latest firmware.

All worked well for about 2 months. Yesterday whilst playing Automobilista 2, the wheel suddenly lost connection mid race. This affected the pedals as well. Within the Fanatec software it said No Fanatec Device Found! I did all of the usual things. Rebooted. Uninstalled drivers, checked cables, tried different USB ports and new cables.

I finally did a forced firmware update (Power on while holding the base power button). This went through ok, and allowed me to race for about 10 minutes. The wheel disconnected on lap 2.

Now, and before, If i remove the power from the base, and then plug back in, the Fanatec software shows the base connected for about 1 second. Then goes back to 'No Fanatec Device Found!'

Also, the base power light pulses red, and only option is to hold in for about 5 seconds until its forced off. If i then switch back on , it will rotate the wheel slightly, the base shows up in Fanatec software, but then back to the disconnected state.

I have opened a ticket, but response says i may have to wait up to 7 days. Not great!


This is a post from another user. Just tried, and device pops up again in the Fanatec software. I will give it a go and see how long it lasts. Fingers crossed.

Hi all, first post from a very new customer. Hopefully this helps someone as I had many hours of frustration before I figured it out:

Symptom: I’d be using my new products (CSL DD, podium hub, quick release, button module endurance, GT3 wheel) for a number of hours without issue. Then all of a sudden the wheel went limp, steering and buttons stopped working, Fanatec software and Windows could no longer see my connected devices. Display went dead on my BME, no buttons working. Nothing.

After taking everything apart and putting it back together again, re-installation of software, taking out all other USB devices, reseating all cables… no joy. I searched on this forum and found one helpful post (that I can no longer find, but it’s there somewhere) that gave me a clue as to what to do but didn’t quite understand the solution in the way that it was presented.

Solution: There is a black plastic collar with a single bolt on the CSL DD shaft. I unscrewed it using a hex key, then pushed in the shaft from the wheel assembly, as if to try to push it into the CSL DD, then tighten up the bolt on the collar again. Indeed the shaft moved inwards slightly. Magic - everything detected immediately! It seems that the shaft from the quick release/podium hub had worked its way loose. Probably from the plethora of terrible accidents that I caused in-game. The shaft must be pushed right in and the collar tight for it to work.

So if your steering wheel stops working, don’t panic… the solution could be just to deal with the one bolt on the collar and to push everything tight together. Good luck!


Any ideas.


Sign In or Register to comment.