Clubsport Formula V2.5x

Hi, today I was playing dirt rally, mid of stint I tried to shift down, nothing happened. Briefly after that my game pauses ( Wheel is disconnected ). After that my wheel starts slightly vibrating and fanatec control panel doesn't recognize any of my fanatec gear anymore. When I take my wheel off from CSL DD, then fanatec control panel shows all my connected equipment. When I pop my wheel back in to base, It opens up "Clubsport formula 2.5x UPDATER" I do the update, vibrating stops, and after 5 seconds it starts again and all devices disconnected and it opens updater again. What to do guys?


  • the wheel is in update loop. I tried to uninstall all firmwares and re-installing them. Didn't work. I hold power button on CSL DD for 10seconds to force updates for CSL base and motor, all went fine. When I pop my wheel back in, all disconnects and It opens Formula v2.5x updater up once again.

  • Ok. Arne Digernes had found solution to this. Insane that this trick worked. This is straight copy pasta from his post.

    "figured out what the problem was. The black collar that holds the motor shaft went loose from factory and the shaft probably went off a little bit while I was driving. I noticed the gap between both pieces to be strangely long so I uncrewed the black collar and pushed the shaft into the hole and it went in like 2 or 3 mm. Then I screwed the black collar back and everything worked fine. Hope it helps for other people. Greetings."

    After all night trying to install new firmwares etc, it was only one screw that was the problem. Many thanks to this guy!

Sign In or Register to comment.