CSl DD not recognized by computer

My CSL DD is no longer being recognized by my computer.

It powers on and does the self check as normal, shows the firmware for the base and the wheel, however after that it fails to connect to my PC. Im up to date on the drivers, tried the driver repair, tried deleting and reinstalling the drivers. No matter what I try though, it never connects to the PC.

I have tried a different USB C cable with a known good one, and tried connecting a different device to my computer with the supplied fanatec cable. I was able to rule out that the cable is the issue with this method.

I have also tried reseating the wheel shaft and that also does not resolve the issue. I am left with no other option than to believe that the wheel base is no longer communicating to the PC via the USB-C port. And that the only option is to RMA the base.

I am open to other suggestions until support reaches out to me via my open support ticket. Needless to say, this is very frustrating as at best, I believe that Im going to be looking at a month downtime before I get an answer and/or a replacement base.


  • Hello, all the same here.

    suddenly there is no connection to the Wheel and the Base anymore.

    If I change to XBOX-Mode, the change is written down. If I change back, the sound is to hear, but there is no detection. I changed USB-Ports, but does not change anything. Please help!

  • When did you guys receive your base? I presume they are new?

  • Hello

    this is actually the same problem that I’m having right now. I tried installing and re-installing the drivers even tried the older version, also tried resetting the shaft and tightening the clamp and pc still doesn’t recognized it. Need some guidance! TIA

Sign In or Register to comment.