FFB loss during racing


When in different games, the FFB suddenly drops completely out and after a few seconds it slowly comes back.

Sometimes the wheel even shows something in the display of the wheel. After restarting the wheel, it works fine for some time.

Wheel display:

YT Video of the issue can you see here (its hard to see on camera): https://www.youtube.com/watch?v=cSpiE5AdsVY

My wheels are CSL Universal HubCSL Elite Steering Wheel WRC and ClubSport Steering Wheel Formula V2 and it happens with all three of them in different games.

I had contact with the Fanatec Support, they gave me some tips to try fixing it:

-installing new drivers/reinstalling driver

-tighten screws in between the hub and wheel

-sent over some logs

Nothing fixed the problem so I sent it to Fanatecs repair shop and got a new motor and a power cable.

After recieving it back two days ago and testing in different games (Asseto corsa, carXDrift, ETS2) the problem is still there.

Also I bought an external USB card but it didnt fix it either and tried every USB slot on my PC.

The problem itself started occuring when i switched from Ryzen CPU to Intel, I think this has to be software related, but unfortunetaly i cannot remember what driver version I had before reinstalling. But I tried almost every old driver they provide on the homepage.


  • it might be your chipset drivers. if you can, clean out yr hard drive and re-install the drivers and windows. you would have a new motherboard as well too isn't it?

  • Hey,

    I did reinstall everything after i switched the mainboard and CPU, formatted the m2 ssd as well and flashed the bios.

  • So I did plug the wheel into another PC and it has the same issues...

    It either has to be a hardware problem or the firmware, since it seem to be saved somewhere in the hardware.

    I will try some older firmware versions, if this does not work I'm doomed, i guess.

  • Joseph GossenJoseph Gossen Member, Moderator
    edited September 2021

    Hi Pascal,

    Please contact the support team and open a ticket for this issue.

Sign In or Register to comment.