Shifter Stuck in Calibration on Wheel

Tried following the steps per the YouTube video for setting up the shifter, but the wheel continues to just say Shift Cal. Even went the setup on the Fanatec Control Panel but still the wheel stays the same. I tried it on my WRC wheel and my Mclaren wheel and still nothing changed. What am I missing?


  • hello

    what worked for me was turning my steering wheel to the left / right at the end and hold ik like that so you can feel the tension on it. than i could callibrate my shifter without any problems

    it was wierd tho... i also have seen that they take the shifter of the rig and could calibrate like that ( grounding issue )

  • I actually reached out to support and they are sending me a specific rj12 cable , as apparently it seems to be something with the csl dd wheelbase

  • Tim KocksTim Kocks Member
    edited November 2021

    Hmm, I found a 'solution' in an older thread (CSL DD & H Pattern Shifting Not Calibrating) through a ggl search.

    "Mine calibrated after someone suggested removing it from the base connection. In my case I detached it from my GT Omega Apex Wheelstand, put it on my lap/knee and it calibrated. Put it back on the base and it is still working today. I have not changed the Fanatec cable. It was some interference with the wheelstand."

    "Just a informational tip. You have to do this with every firmware update. I had to do it when I upgraded to the next version."

    "I just had the same problem. Couldn't get it to calibrate. USB connected or not.. Shifter mounted to the rig or not. As a final attempt, I connected the shifter with the short 30 cm (?) cable instead the long one, and TADA... it worked to calibrate. After calibration, I can use the long cable again!"

    Haven't tried it yet, as I'd have to undo my cable routing.

    Someone also mentioned it worked for him by just doing the calibration through the wheel with the usb cable detached from the base. This didn't work for me or most in the thread.

  • @Tim Kocks

    thanks for your informations!

    I also had problems with the calibration of my Shifter. Tried it with both cables and it didnt work.

    Then I tried to unmount it from the rig, and while holding the shifter in my hands the calibration instantly worked with the short cable!

    Now i mounted it back to the rig and can use it with the long cable :)

  • Glad it worked for you!

    I got back an answer from Fanatec. According to them, using the short cable is currently one of their support suggestions for calibration issues.

    They said it could also be could be related to grounding problems on the rig. Hence the dismounting of it working. They are going to look into taking up this into their suggestions.

    I hope they'll put these in the manual if this is not something quickly solvable on the production/software end on their side.

Sign In or Register to comment.