Firmware update ClubSport Pedals V3 inverted

Hi Fanatec,

I have just received my new fanatec setup, DD1, F1 wheel, ClubSport Pedals V3 inverted.

I downloaded the latest driver package, 429. This installs the 'Fanatec Control Panel'. Here we can update firmware of the attached devices. Almost everything updated fine... just not the pedals.

I have the pedals connected directly to my PC but the 'Fanatec Firmware manager' won't let me update the pedals. The only message I get from your software is: '[ClubSport Pedals V3 and CSL Elite Pedals LC can only be updated when connected to the PC directly via USB]'. Like I said before.... the pedals ARE connected to my PC directly via USB.

Is this a known issue? Will you be fixing this? Is the controller on my ClubSport Pedals V3 broken? I'd like to know from you.



I have tried grabbing another driver (402) directly from this page: ClubSport Pedals V3 inverted | Fanatec But, when I unzip the file and try to run the x64 package I get an error message from the Fanatec software: 'You have already installed a newer driver package'

Thanks in advance for your help.

Comments

  • You dont have them also connected via RJ12 to the base by any Chance?!

  • They are. But I also tried without the RJ12 attached to the base. But then the 'Fanatec Control Panel' doesn't recognize anything attached. The 'Fanatec Control Panel' software only recognizes the pedals if the base is attached to the PC as well.

  • edited November 2021

    They are?

    Well.. Then you most likely bricked your pedals.

    NEVER EVER connect then both via USB and RJ12 at the same time!!! This will damaged the PCBA of the pedals which is not covered by warranty.

    For pedal update they have to be connected via USB ONLY.

    You can try newest driver 431 but if it's still fails well then they are broken.

    But that's not bad because the newest firmware 1.32 for them is not good anyway and the good old 1.30 is still the best firmware.

  • As I'm thinking about your comment and my reaction on that again... it makes sense to me that my PC is not recognizing the pedals if they are connected solely, there is no power brick attached to the pedals. The power brick goes into the DD1.

  • edited November 2021

    The pedals dont need power. They are powered by USB when connected via USB - thats enough.

    When connected to Base they get power through that. But as said, do NEVER connect them both at the same time.

  • They are not bricked. They work when testing in 'Fanatec Control Panel' and when racing. The problem I have is that I can't update the firmware of the pedals.

    I'll give it some more tries and wait for an official Fanatec rep to reply. Otherwise I'll rma the products. Thanks for your replies Maurice.

Sign In or Register to comment.