New CSL DD not feeling right

Johnny MatosJohnny Matos Member
edited May 12 in Off Topic

Tried out my new CSL DD and It has the weird buzzing sensation some people report when it's turned on (even if the PC is not powered). It is sometimes felt while driving, specially on the shifter paddles. This morning the tarmac in 3 different games felt like "the floor is sandpaper". It comes and goes but when it went away I started noticing that the center of the wheel is not picking as much detail as the sides. When I go over kerbs in a straight line I can't feel them as much as if I'm turning over them. It's there but it feels like a controller vibration. When holding the wheel straight there's almost no feel from the road, but it starts to become apparent when I turn the wheel slightly. I'm using 100% FFB with the 8nm power pack and I have tried it in AC, ACC and AMS2 with almost the same results with different in game FFB settings. I have tried lowering FEI and whatnot but I shouldn't have to do that since people who have the same values as me don't seem to have this issue. I'm using the table clamp and I know fidelity is lost but that doesn't justify losing detail on the straights. My desk doesn't wobble as much as I would have expected, especially since it's not the sturdiest, and that leaves me with the impression that I'm not getting the full force in some situation. The dampening, compression and counterweight feel good and strong though unlike some finer details, so at least it can put up a fight in that sense. I saw the Youtuber Jardier using it in a desk at 70% FFB on the wheel and 70% in game (ACC) and the desk was wobbling and he said he felt a lot of force and detail. Why do I have to use 100% to feel less than what he reports? Sometimes the fine details feel like a PS4 controller vibrating when going in a straight line. The worst part is that I'm outside the US and can't RMA it in case the base is the problem. I even asked before buying if it's possible to ensure I don't get a dud and I got a reply saying that this production issue (the static feeling) had been solved, which apparently is not true. I don't know about the center feeling weak though, never heard of anyone with that issue. FML, I'm a sad camper.

EDIT: yes, I have the latest drivers

Comments

  • Search through my posts there are some Test Motor Firmware versions fanatec sent me. Try these two versions and see if that solves your issue. If not, get ready for a long journey in the customer care line.

  • IMPORTANT UPDATE: one day later and the wheel is feeling amazing. However the vibration is there but it's very faint and I can only feel it through the shifters when I'm not driving. Also the center feels a little more solid and cleaner. I hope it doesn't misbehave again.

  • I have found it’s an unstable problem, sometimes it’s there sometimes not. Sometimes strong sometimes weak I’m trying to ignore it for now but if it gets any worse I will RMA a second time.

  • By the way I rolled back to the official motor 1.0.2.2 firmware and the grainy feeling with this wheel is worse (also with the previous wheel) going back to the test Motor Firmware they sent me (1.0.2.3] the graininess and vibration calms down but it’s still up and down. Perhaps there is hope that a new official motor firmware will solve this problem. For now due to lack of customer care at the moment I will continue to live with this issue and monitor the situation.

  • Johnny MatosJohnny Matos Member
    edited May 13

    Do they have to send me the test firmware or can I find it on my own? btw I am also having an issue with the wheel staying centered even when I'm running a game. The FFB should be stronger than the magnetic pull but it's not and it always goes to the left the second I put my hands off the wheel. Center calibration has nothing to do with it. Do you have that as well?

  • Can you just tell me how to get 1.0.2.3 or give me a link to whatever post you are referring to? I can't find anything

  • edited May 15

    They sent me the motor firmware by email in a support exchange.

    You wil find it here: https://forum.fanatec.com/discussion/comment/84469#Comment_84469

  • yes the wheel won't necessarily rest at centre this is normal due to the magnets. The main thing is that you calibrate it and the actual centre is 0.

  • Motor firmware 1.0.2.3 seems to have calmed the issue for now!

  • Good to hear, for me even with 1.0.2.3 this scratch feeling still comes and goes and still manages to irritate me. I wonder if they will release an official firmware at some point which will solve the issue.

  • Now I'm dealing with my shaft bending to the left. It got worse over a few days and reseating it won't fix the issue. It might be the motor stem. First time Fanatec experience and I'm already thinking of giving up sim racing. Honestly, it annoys me so much that they get to enjoy the full extent of my money and I get to have a shitty experience...

  • Really a disaster experience, for me the best part of this journey was receiving the package and unboxing, afterwards it was all downhill from there. I really can understand your disappointment. Feels like I’m being pulled along on a journey I don’t want to be on. My expectations are zero now….it’s the only way to survive this.

  • Dominic BrennanDominic Brennan Member, Administrator

    Hi guys,

    I'm sorry to hear about your experiences. If the wheel base feels different from one day to the next, or after a short while during use, then it could be a defective unit, and our support team will try to help you until you are satisfied. It is unfortunate that the team is dealing with a large backlog of tickets at the moment, but they will get to you and they will help you.


    [Fanatec Community Manager]

Sign In or Register to comment.