Fanatec CSL DD not being detected (No Fanatec device found!)

Hello guys,

Been on a CSL DD with a McLaren GT3 V2 Wheel and the standard CSL Pedals for a while now. There was a phase where I didn't use the wheel, and I think I never updated the firmware lol.

So I got into Sim Racing again and started racing on my Xbox a bit (F1 2021) and everything worked perfectly fine. Today, I bought AC for PC and wanted to connect my CSL DD including the other stuff to my computer.

Doesn't work.

Everytime, the Fanatec Control Panel says "No Fanatec device found".

I have tried de- and reinstalling the drivers again, switching USB cables, using the "repair" button in the driver files...nothing has worked.

Some extra information: like I said, I was too scared to download drivers in the past. When I did try it a few months ago (on another PC), it did indeed detect all accessories and the wheel base. When I tried to update the firmware, it got stuck and I thought I bricked my DD, so I pulled it out. It managed to survive and since then, I never tried it again.

But because I got a new PC with Assetto Corsa on it, I really want to try this, but til now no results.

Been searching for a solution all day long. Does someone have a tip/solution for this one?

Really appreciate your help, thanks in advance.

Comments

  • Is it in pc mode? Red led on base. Green led is Xbox mode

  • David ChiengDavid Chieng Member
    edited May 30

    Try compatible mode as well… faint yellow.

    I think he must have sorted this. No more comments since. All is good?

    Would be good if you decide to come on here to ask for ideas, to then also come back and let us know once it has worked out and what you did, no matter how silly it was, just so we all will learn from it. Cheers.

  • you need to reinstall the drivers. i think its related to windows updates. i randomly have the same problem that my base is not found. its always when a new windows update was screwing something up which might have to do with usb things. just a thought i dont know. but that solves it for me at least

Sign In or Register to comment.