F1 22 Completely Unplayable

Hi there. So I'm having any issue when loading the game into a time trial or any kind of on track, were the game is constantly stuttering, lagging, freezing and the ffb kicking in and out. I know the game has just been semi launched for those that pre ordered the early access one but it shouldn't be this bad. As soon as the game gives me control (in TT) the game complete freaks out and stutters and lags so bad were i cant even make it 100 meters down track.

Pre much all my in game settings for graphics are set to low, or medium.

Is there anything I can do or am I stuck until codemasters release the first update at global launch on the 1st.

Comments

  • Joshua LudwigJoshua Ludwig Member
    edited June 29

    I had the same issue. If I unplugged the wheels and pedals it ran perfect. As soon as I put the wheel on the benchmark would go from 138 FPS to 45 FPS with audio chopping.

    https://forum.fanatec.com/discussion/26249/solved-f1-22-pc-extreme-lagging-when-ffb-activates#latest

    I followed this persons advice. Installed the drivers and it didn't fix it. So then I unmounted my pedals so I could swap from the USB cord to the phone like data cable, and believe it or not it 100% fixed my problem. I never had an issue with this in F1 2019 - 2021.

    Although I will say I had the bright idea of updating my Fanatec drivers. I initially went from 328 - 439. I probably installed 328 sometime in early 2020 when I built this computer. I found the thread above and installed 440 and swapped the cable.

  • AjtAjt Member

    Workaround if you can’t plug your pedals into your base or it doesn’t work for you:

     

    1. Install VJoy. Windows 11 users will want https://sourceforge.net/projects/vjoystick/files/Beta%202.x/2.1.9.1-160719/

    2. Install HidHide https://github.com/ViGEm/HidHide/releases/tag/v1.2.98.0

    3. Install Joystick Gremlin

    4. Setup a new vJoy device with 3 axes (one for each pedal)

    5. In Joystick Gremlin use the Remap function to remap your pedal rotation axes (x/y/z on mine) to vJoy XRotation, YR, ZR axes.

    6. Save that profile and then activate it

    7. Use HidHide to hide the Fanatec USB pedals

    8. Go into F1 22, remap your controls; you should see vJoy Device 1 as one of the required devices for that profile now instead of Fanatec USB Pedals.

    9. Play and enjoy.

    NB - there are a few reboots you'll have to do in here :-)

  • Try to plug your pedals directly into the wheelbase, then restart your pc aswell as your wheelbase and then try again.

  • Thank you for this suggestion but it didn't work for me.

    I am using Fanatec CSL LC Pedals with Thrustmaster T300 RS Wheelbase. Both connected via usb. I have no other option than that.

    I remapped my pedals as vjoy device and hid the csl pedals alright. I remapped all the keys in the f1 22 game. I can race with these settings but FPS gradually drops from 90s to mid 20 range. I don't think I am doing anything wrong but maybe someone has a tip.

  • Ramazan DurakRamazan Durak Member
    edited July 1

    @ajt Oh, on the contrary, it worked fine. What I did wrong was, I didn't use hidhide, I used hidguardian. Well that was wrong. After using hidhide correctly all the FPS problems were just gone.

    But I have a problem with joystickgremlin right now. pedals stop working after some time like 5-10 laps time. I think computer thinks csl lc pedals are not working and puts it to idle (I checked and usb power saving is not active, so this isn't the problem), hence, csl pedals tab in joystickgremlin disappears. only way for me to regain connection to pedals is to restart josytickgremlin after disabling hidhide.

    I need a solution for this. the connection usually gets lost during the middle of the race.

  • So my problem has been partially resolved. My game is no longer laggy and unplayable. Everything works perfectly now. My only issue is that the audio is still very choppy throughout the whole playing time and in the menu of my team. Until I go back to the main menu, that the audio is no longer chopping.


    Any solutions for this?

  • How did you fix the lag? I cant seem to find any solution for it.

  • All I did was connect my pedals to the base. I use to have them connected via USB. But I'm still having audio chopping. Not sure how to fix that.

  • Does this problem still exist? Looking to buy pedals for a nephew, and he would need to connect directly with USB?

Sign In or Register to comment.