Base not detecting rim any more :(

As per title, wheel base is not detecting the rim on my DD Pro.

Have tried re-seating shaft multiple times. Honestly not sure what happened as it has been working for months without issue.

Base turns on then continuously cycles between the modes.


  • Did it stop working out of nowhere?

    Or did you do any firmware update and after it stopped working?

  • Out of nowhere. Worked perfectly on GT7 on the Thursday last week, didn't play on the Friday. Started it up on the Saturday and noticed the wheel didn't light up as it usually does and also the ps button wouldn't work to set it as a "controller".

    Seems you can't update the firmware until the base and wheel are acknowledged by the Fanatec control panel. As the base is just cycling through the modes (colours) it never gets that far.

    Hopefully support can help me here.

  • edited November 2022

    Wow 2 emails from Fanatec support in a single day regarding this issue. Completely unexpected lol

    Having ordered a Maclaren GT3 wheel over the weekend, we've agreed to wait until that arrives to test whether its the original wheel or the wheel base! (heres hoping its just a faulty original wheel)

  • After ages waiting for UPS, still the same issue, even with the new rim.


  • An update for continuity sake:

    Support raised an RMA which was collected Monday this week and delivered on Tuesday. No further update regarding whats wrong with it.

    Must say, the support team have been great! Quick email responses from them

  • Update:

    Got a new wheel base through RMA. Works perfectly now :)

    Thanks Fanatec support for your help throughout.

Sign In or Register to comment.