Fanatec Control Panel freezes up completely when I plug in CSL Elite Pedals w/ Load Cell kit (v1)


I have the CSL Elite Pedals with the Load Cell kit and I connect the pedals to my PC via USB.

It used to be that I could run the "Set up USB game controllers" app in windows, select the pedals, hit 'properties' and the pedals calibration screen would come up (where I could set brakeforce, and manually set a min/max on the pedal inputs)

I used to also be able to run the Fanatec Control Panel and see my pedals, depress them and see the inputs on screen, etc.

Now, after not playing for ~1 month, when I run "Set up USB game controllers" and hit 'properties', the calibration window does not come up. Instead I get:

If I run the Fanatec Control Panel with the pedals plugged in, the fanatec control panel app hangs on loading, never fully loads, and I can't even force it exit using task manager.

If I unplug the pedals from USB, the fanatec control panel loads just fine and I can see my wheelbase listed.

If I have the Fanatec Control Panel running without the pedals plugged in via USB, and I then plug them in via USB, the fanatec control panel immediately hangs up/freezes and cannot be force-closed using task manager.

The pedals show up correctly in windows Device Manager:

They also are listed properly in the Set up USB game controllers window:

Any ideas on what is wrong or how to fix it? Whatever is causing the above issues also causes iRacing to fail to load the simulation when attempting a test drive, it locks up loading at 5% if my pedals are plugged in. If I unplug my pedals, iRacing test drive session loads without issue. But, no pedals means no driving so...

I've tested driver versions 423, 447 and 450. Same issue across all driver versions.

Testing involves: unplugging pedals, uninstalling driver, manually removing pedals from device manager, rebooting, reinstalling drivers, rebooting, plugging in pedals, then attempting to load properties page of game controllers screen, and then attempting to open Fanatec Control Panel.

In all test cases, the pedal calibration screen does NOT open on clicking 'properties' on the set up USB game controllers window, and in all cases, fanatec control panel either doesn't load if pedals are plugged in, or locks up after successfully loading without pedals plugged in, if I then plug the pedals in with it open.

I'm at my wits end testing this and hope someone has a solution to this issue, as I cannot race or practice without working pedals and the last time I loaded up iracing for a test drive a month ago everything was working fine.

There aren't separate drivers for just the pedals/USB connection that I just can't locate, are there? That should all be part of the fanatec drivers?



  • Not sure what your setup is. Do you own a Fanatec wheelbase? Or are you using a non-Fanatec Wheelbase?

    If you use a non-Fanatec wheelbase, try uninstalling the Wheelbase driver software and pedals driver. So install the Fanatec driver for the pedals first, make sure they works, and only then, install the driver software for the wheelbase.

    I had the exact same problem using CSL Pedals with a Logitech G29 wheel, and somehow managed to get them to work together by changing the install order of the two softwares.

  • edited March 2023

    First, thank you for responding

    Do you have a link to the pedals driver? That was the first thing I searched for and could not find. If I go to there is only one driver available, there is no driver link on the product downloads page for the CSL Elite Pedals with Load Cell kit (; the manual talks about installing drivers for the LC pedals but I cannot locate where these pedal drivers are available for download.

    My setup is CSW 2.5 wheelbase, CSL Elite pedals (v1, linked above) with load cell kit, and the formula 2021 wheel.

  • The driver software is unique for all Fanatec peripherals. Then there are no other options than the ones you've tried.

    If you have a Fanatec base you can connect the pedals directly to the wheelbase, and they should work.

  • I found the problem; it wasn't drivers it wasn't even the pedals or usb connection.

    It was Citrix Workspace. I was required to install this on my computer in order to be able to work from home for my job.

    I have no idea why it was causing these issues with my USB pedals, but uninstalling it completely fixed the problem. I can now open Fanatec Control Panel, see my pedals, and calibrate them/set brake force/set min/max all the stuff I need to do.

    Looks like I'll just be making installing citrix workspace at the beginning of my workday and uninstalling it at the end of my workday the new routine.

    Hopefully if anyone else is in the same boat and reads this, and is running Citrix Workspace due to a WFH situation, it will help them realize the issue.

    I'm really glad to have found the problem, but also fairly upset about the reason.

Sign In or Register to comment.