ClubSport Shifter SQ 1.5 registering incorrect gears in H-shifter mode

Adrian ChoAdrian Cho Member
edited August 29 in Fanatec Other

My shifter is only a couple of weeks old and I've had no issue with it so far. However as of today it seems to have gone crazy.

The problem is that R, 1, 3, 5, and 7 are all recognized as reverse and 2, 4, and 6 are all seen as 6 . If I go into the H-Shifter Calibration in the Fanatec Control Panel, it seems to accept all the calibration but then things are still wrong. I just tried the calibration again and now R is seen as R, 1, 3, 5, and 7 are all see as 1 and 2, 4 and 6 are all seen as 2. It seems like it is possibly somehow stuck between the sequential shifter mode (which I never use) and the H-shifter mode but I've tried toggling the physical switch on the unit several times.


  • edited August 29

    Which Port on the back of the Base is the Shifter plugged into?

  • It's in Shifter 1 in the DD base. That's how I've had it previously and it was working fine before.

  • I just tried it in the Shifter 2 port and it's no better in fact it's worse as it now saying it is in 6 all the time even after running through the calibration. :(

    It at least seem to work fine in sequential mode.

  • Adrian ChoAdrian Cho Member
    edited August 29

    It does seem like something is wrong internally in it. It's only a couple of weeks old and I thought it seemed pretty bulletproof. :( All drivers and firmware are up to date.

  • Please plug it back into port1 as only Port1 is designed for H-Pattern for now.

    Then do a new Shifter calibration.

    If it still fails then it's either something broken inside or your Rig suffers from EMI issues where you should try to ground your rig and maybe add ferrite cores to the RJ12 cable.

  • Yeah I already put it back in port 1 and did calibration and same result. Something must be broken internally because nothing has changed in the rig at all. Disappointing quality especially given the price.

  • I also just tried a different RJ cable that came with it and same result.

  • Could still be EMI.

  • I took a quick look inside and nothing obvious. :( I could try adding some ferrite cores around the cable but I have my doubts it would make any diference.

  • after you look inside does it started work because there is some talks that it could magicaly go away if todo this.

  • This thread might give you some ideas of things you can try:

  • This shifter has some kind of misconstruction. On the Internet you will find 1000 different threads or discussions on this subject. There are solutions like the tape behind the board, which helps for a while but the problems always come back, the problem has existed for years, which can also be seen in the countless threads here in the Fanatec forum.

  • I have a SHH Shifter, and have had similar problems. There are videos talking about similar issues with Thrustmaster and possibly Moza as well. In my case the problem is due to a combination of Hall sensors and bad grounding. Probably because I'm using a USB HUB to connect my shifter, and it's possible that the ground connection is broken or inadequate. I had no such problems until I connected the gearbox directly to a PC USB socket. I made a connection with a cable, from the USB socket of the shifter to the electrical ground of my house, which solved the problem completely.

    The Hall effect is due to a displacement of electric charges. It is possible that this will be affected by EMI or electrostatic charges. All things that's supposed to flow on the ground, but for some reason doesn't.

    It's due to bad grounding. In fact it is sufficient to open the Shifter to solve the problem. By touching the internal boards we discharge them to the ground through our body.

  • Check the small cables leading from the end of the shift handle where it connects to the sensors. There are 2 with 4 wires each a couple of inches long. A borken wire or loose/bad connection can cause similar symptoms - I had this problem, new cable fixed it

  • mark dinsdalemark dinsdale Member
    edited September 20

    im now getting this issue aswell and sorry but we pay £300 for a product and then we have to mess with the insides cos Fantec made it so bad ( sorry i mean china) time to look for a better shifte imo

  • As most of us have heard one of the "solutions" Fanatec recommendations is to take the unit apart, disconnect/reconnect one of the internal cables, then put it back together. I just went through this again and find it really annoying.

    If this is some kind of grounding issue, is there a way we can add our own ground? Something that would be always hooked up and run to the outside of the shifter.

Sign In or Register to comment.