Unable to process order.

When I try to pay for my order I get hijacked to a page that does not exist. The page is an Ayden page, but one that does not exist. I have purchased previously. I am logged into my account. I have my order and I am ready to drop $2000. Has anyone seen this and does anyone have a solution?


  • Use a different browser

  • I have. Tried 3 different browsers. The address always ends up the same. Thanks!

  • Dominic BrennanDominic Brennan Member, Administrator

    Hi Bobby, I can see that you already have a question on our system, customer service should get back to you soon. Alternatively you can try the Live Chat, which is active whenever you see the headset icon on the site:

    [Fanatec Community Manager]

  • LOL I just want to give you money.

  • I have the same problem. I've tried multiple web browsers and tried on different days. I've contacted support 4 different times and received the response saying to try again and reach out if it doesn't work. Not sure what to do next.

  • How is this still an issue? I have been trying to place my order for days with this same Adyen webpage error. If you Google it, it has been going on consistently for YEARS. WTH Fanatec figure out how to setup a web store already. How ridiculous!


    On the Adyen page that comes up in error. I hit the back button (Chrome). The page reloads that asks for CC number and EXP and CCV. This time instead of using my VISA, I typed in my Discover, even though they do not show that they take Discover on the checkout page (no little icon for Discover). Well, what do you know? Asks me for a cell-phone text code confirmation and then it processed with a receipt. So maybe keep trying or swap out cards (try Discover if you have one).

  • I just ended up using paypal.

  • I have also tried multiple browsers but still, I am not able to place my order. chatroulette ometv

    How can I proceed it? Please help.

Sign In or Register to comment.