Recent Windows 10 Update Temporarily Bricked my Podium Wheelbase

A couple of days ago, a Windows 10 update that I simply installed without thinking about it totally broke my Podium wheelbase's compatibility with my PC. I spent about 12 hours panicking and trying everything I could think of to fix this issue. Just a bit ago, I decided to try rolling back to a previous windows build, and it did the trick. If you own either of the DD products, but specifically the DD1, be careful about updating your PC if you have Windows 10, and roll back to a previous Windows build immediately if you have updated your Windows 10 PC in the past 48 hours.


  • no problems with the lvery latest KB update of Windows 10 here, so it seems to be more a problem on your specific machine and no global issue...
  • It is normal that Win10 updates corrupt the Fanatec driver. Uninstalling the Fanatec driver + Win10 reboot + intalling Fanatec driver + Win10 reboot usually fixes this. If Windows still doesn't see the wheel base after this, there's something in the handling of USB devices in Win10 that got broken I guess.

    With a previous Win10 update, there was a problem if you had a USB drive connected to your PC during the update. Perhaps something similar is going on here, and disconnecting all Fanatec gear from your PC before doing the Win10 update (and re-installing the Fanatec driver afterwards as described above) solves it.
  • I had exactly the same problem, rolling back the windows update solved it....
  • Hi,

    i don’t understand why fanatec doesn’t fix this issue. I have a windows 10 family computer. I can’t get to access the podium wheel base. All I want is to update the firmwire. I don’t have another pc and I don’t intend to buy a new windows OS just for this. Any solution.

  • whats your issue to this 1 year old thread?

    There is no known issue with Windows other that you have to re-install the Fanatec driver everytime you do one of the big Windows Updates, but thats a Windows issue, not Fanatec. So, nothing to fix.

Sign In or Register to comment.