Freezing, locking up, absolute annoyance

I ran a CSW 2.5 for 3 years now, over the last year or so it laid dormant as I was in the middle of a move. Long story short, I got back into racing and I started having this odd problem in Dirt Rally 2 where the wheel freezes for a second or maybe 1500 ms and then goes back to normal. By freezing I mean, whatever steering degree, gas, brake, etc. that was engaged at the time of the freeze stays constant during this 1-2 second blip. This is extremely aggravating especially when you're mid turn and you end up down the hill ruining your whole stage since you only have so many restarts. It honestly made racing impossible and I'm at my wits end as I cannot seem to get any answers whatsoever. This by the way was happening with the old official drivers on the Fanatec page. So I decided to give the BETA ones a try and now I'm running the latest drivers and firmware:

PC Driver: 365

Wheel Base FW: 672

Wheel Base Motor FW: 22

This didn't really do much besides killing my universal hub's buttons. So I reverted back to 347, motor back to 18. That brought back my universal hub buttons but the freezing is now even worse. It doesn't really seem to matter what firmware/driver combo I use. The wheel worked perfectly fine for the 2+ years. So it must be some sort of a hardware fault and I'm assuming but what I'm reading here is that its a lost cause.

I must say this is quite frustrating, its very random to reproduce which means I will have to strap a camera to my feet/wheel and overlay it on top of the screen to show what is happening. There's one video on YT that showcases this very problem:

In his case, its happening for a bit longer.. 3ish seconds. But same exact symptoms.

Is this pretty much a death sentence for my wheel? It's an utter waste as I have two choices, get another Fanatec compatible base that works with my pedals, shifter and e-brake or start over from scratch.

Thank you.



  • Are you using a usb3 or usb2 port?

    Have you tried Turing off the USB power saver off?

  • For the longest time it remained plugged to a USB3.0 port in the back of my PC. But I just moved it to a USB2.0 port (Still using the same PC) after reading that it may be better.

    Also, in Device Manager I noticed I have quite a few Root hubs and Generic hubs for USB, some had the power save on some had it off. I have since turned all of them off. Going to attempt to run a few trials and see what happens.

  • Just wanted to post here to update. So far I believe the issue has been resolved. I don't what of the following fixed it but this is what I did:

    1. Replaced USB Cable + Extension to a single 90 degree angle long USB cable (just search on amazon, there are plenty of options).
    2. Plugged the cable to the back of the case (was in front before).
    3. Plugged it into a USB2.0 port (was previously in a USB3.0 port)
    4. Disabled power management on all USB controllers + hubs.

    That made quite a significant change to how the wheel feels, it's definitely running as it should now. I just hope I can just go off and race in peace.

    Hope this helps anyone else that's experiencing this maddening issue. And thanks to Marcel for giving me all of these suggestions.

Sign In or Register to comment.