CSL Wheel Base Wont Work ONLY 8 WEEKS OLD

CSL playstation base and formula v wheel

Tried everything. PC doesn't recognise the wheel base, tried changing ports and leads, reinstalling drivers and firmware. Also plugged it into PS4 as is compatible and still nothing.

Red LED flashes when i activate the bootloader by holding in the button. is that normal. What dose it mean ?

As a company that is a part of F1 and iracing I thought the goods would be made to a good standard and reliable. I thought I was doing the right thing. I even recommended it to a few friends that want to get into sim racing. IVE TOLD THEM TO PUT THERE ORDER ON HOLD.

I will see what the after sales and tec support are like before I recommend it to anyone else.

I upgraded from a £150 Logitec wheel which ive had for over a year. No problems what so ever.

If the problem cant be resolved how do I send my faulty equipment back for repair or replacement ?????

Any help would be much appreciated !!!



  • Dominic BrennanDominic Brennan Member, Administrator

    Hi Raymond,

    I can see you have opened a support ticket. The team will get back to you as soon as possible to resolve this for you.

    [Fanatec Community Manager]

Sign In or Register to comment.