Throttle pedal not working . Please help !

Request !

Hello ! My name is Alexandru Drozan . I have recently bought a loadcell pedal and after I have installed the new electronics module which came with the loadcell pedal , the throttle did not work anymore ( it all started to have a couple of issues after I downloaded the drivers for the loadcell pedal and the wheel ) .

1 . To start with before I bought the loadcell pedal , my throttle and brake pedal ( which is now the clutch ) worked very well in windows 8.1 . After I got the loadcell pedal the throttle could not be seen anymore in the fanatec desktop application . After I downloaded the v311 driver for the loadcell pedal , the fanatec desktop application did not detect the throttle anymore . I tried to download the v328 driver , but still the fanatec desktop application did not manage to detect the throttle pedal . Then I uninstalled windows 8.1 and reinstalled and still I had the same issue . I upgraded to windows 10 and still same issue . None of the both windows could detect the 3rd pedal . Both windows managed to detect the brake and the clutch but the throttle not . Then I searched on youtube what the problem of the throttle could be not working and some people suggested that it could be the potentiometer ( it has dust on it , it should be changed or the potentiometer wheel should be moved a little bit ) . It did not have any dust whatsoever but I cleaned it anyway and when I put it back the potentiometer broke a little bit ( is the 2nd wheel attached to the potentiometer wheel damaged as well ? should it be changed also ? ) . I took the potentiometer back and put it back once again and this time still the throttle did not work again in the fanatec desktop application . I also changed the cables of the clutch and the throttle pedals and the throttle pedal did not work again . What should I do or who do you recommend me to contact who can help me with this issue ? Is there a fanatec admin or hardware/software specialist I should contact ?

2 . Another issue I found was that I found that the pedals and the wheel have different tuning menus . In the tuning menu of the wheel there could be found the pedals as well and in another tuning menu just the pedals . When I tried to push the pedals , the pedals worked only in 1 tuning menu ( is that normal ? Should not the pedals work at the same time in both tunings menu ? ) .

3 . If my potentiometer has a little bit of damage should I continue to use it or should I change it ? The potentiometer though still continued to work . Where from could I get another potentiometer and how much does it cost ?

4 . I also saw that the cables which connect the wheel to the pedals or the pedals to the electronics module through the potentiometer do not make good contact .

5 . I also think that it is very probable that the electonics module I received toghether with the loadcell pedal has got factory errors . The new electronics module manages to see only 2 pedals out of 3 . Must I send for checking the new electronic module which does not work ? It is in warranty .

I also changed the electronics modules . The one which I received with the CSL Elite F1 Set Bundle and the one which I received with the loadcell pedal . In the old electornics module , the one from the CSL Elite F1 Set Bundle , the throttle worked but but the loadcell brake did not and in the newer electronics module , the one which came up with the loadcell pedal the brake and clutch worked but the throttle did not .

6 . Are the fanatec pedals and wheel compatible with windows 10 or should I just let them work on windows 8.1 ?

7 . The loadcell pedal hit 100% in windows 8.1 , without me pushing it too much and it windows 10 it hits only 25% , it could hit a little bit more if i push the pedal a little harder maybe like 30 or 35% ( but I should not because I am not allowed to push the pedal more than 40% ) . Why does the loadcell pedal get in windows 8.1 closer to 100% without pushing hard and in windows 10 with pushing hard it gets close to 35% ?

8 . I also tried to check if the throttle worked with the usb cable but it did not . Then I changed to RJ12 cable and still the throttle did not work again ( I did not use them at the same time just like I was instructed ) . Did this problem start from me downloading the drivers with usb and checking if the pedals and wheel work in the fanatec desktop application ?

9 . I also downloaded the firmware with usb and then the RJ12 cable and the throttle did not work . I then reconnected the pedals to the wheel base but the throttle pedal did not work . Is there a hardware or software problem ?

I hope that I described my issues well and I wish somebody could help me with some solutions to each of them . I can not enjoy my investment and I need it for an online competition .

Thank you very much in advance !

Best regards ,

Alexandru Drozan


  • FaChi RacingFaChi Racing Member
    edited January 2021

    Hello so I wondering if you got it fix??

    If so How?

    I sufering the same problems rhigt now.

  • edited January 2021

    Hello !

    I ordered from Fanatec a new potentiometer for my throttle pedal and a new electronics module . This is how I solved my issue .

    I will also attach here a pdf , which I received from the Fanatec customer service how to install the new potentiometer .

    I am not an electrician and I did not know what had to be changed , that is why I changed both of them and it worked for me in the end .

    Best regards ,

    Alexandru Drozan

  • I have the same issue after installing my LC electronics module. The throttle jack has a poor connection and I have requested a replacement electronics module.

  • Hello ! Did you solve your issue ?


Sign In or Register to comment.