Issue changing to Xbox mode and / or running as an Xbox controller

Hi there, hoping I haven't made some basic rookie error... looking for some advice on what to try next.

I received my Clubsport Formula V2 Wheel yesterday to complete my order, as it was shipped in parts as available. Yesterday was the first time any of the components had been connected / powered on. I connected the wheel and Clubsport V3 pedals to the CSL 1.1 base as per the instructions, connected to my PC and performed the firmware updates as required. I also then calibrated the wheel 

Troubles start here. ..

I cannot regularly or consistently get the system to change from PC mode to xbox mode. It happens very infrequently, and only does so via the mode button, when that decides to work. The wheel button sequence as described in the manual does not function. 

When the wheelbase LED does go green and I connect to my xbox, the Fanatec system locks up. The xbox does not recognize the Fanatec system as a controller, no menus are accessible on the wheel and I cannot even power the system off properly. I need to remove the power source to reset. I have been running Formula 1 2019 and 2020 and neither of these work and both exhibit the same issues as described. .

When the system restarts and self calibrates, more often than not only the red and orange lights illuminate, not the blue... is this normal? 

I dont have any PC based games to connect to so I cant comment on PC based functionality other than the test / firmware update software functioning correctly. The wheel buttons are all recognized, the pedal functions and tests work in the update software as well. I will try with iRacing at some point but havent as yet.

I have tried updating the firmware again and even tried downgrading the firmware as one package for the wheel seems to be a BETA version. I am using the USB cables that came with the hub and the pedals (individually connected) for the software updates and the same USB cable on the hub when trying to connect to Xbox with the pedals connected to the wheel hub via the RJ cable. I am connecting the hub to the front USB on the Xbox but have also tried one on the rear with the same result.

I am currently running PC driver 334, Wheel base Firmware 640, wheel base motor 22 and Steering wheel 34. The pedals were also updated via a separate USB connection but I forgot to capture the version. The wheel base FW reports as being the latest version, wheel base motor FW reports as the latest version, and the Clubsport Steering Wheel Formula V2 reports as being more recent than the default included in the driver package. 

Any thoughts on what I can do to get this working? We have waited a long time to have this delivered and to now not be able to use it as planned / designed is very frustrating, particularly for my kids.

Thanks in advance

Comments

  • **Update - this issues continues - and is duplicated on a second Formula V2 wheel on multiple CSL bases**

    Only a few days after receiving my wheel, my buddy also receives his - the exact same Formula V2 wheel.

    He already has a CSL 1.1 wheelbase and is using another wheel that is complete with the Universal Hub for Xbox . This is all connected to his Xbox One S and everything runs smoothly.

    As a test we disconnect his Universal Hub wheel and put my Formula V2 wheel on and everything fails. Same result as mine, no switching to Xbox mode and no ability to control the game. Couldn't even power off the wheelbase. we switch back to the Universal hub wheel and all goes back to normal and works well. A

    As luck would have it, while I am at his house testing my Formula V2 wheel, his Formula V2 wheel arrives via courier. He unpacks it, plugs it in a instantly the experience is the same as using my wheel on his system. Total FAILURE.

    So to prove this out, I take his Universal Hub wheel to my place and run it on my CSL base connected to my Xbox and it all works perfectly. First time I have had any success in running anything Fanatec on my Xbox. Change wheels again back to my Formula v2 and it all FAILS, again.

    Interestingly his Formula V2 wheel also has one short pin so I am no longer massively concerned about this unless its also a cause of the issue.

    This apparent lack of quality control combined with withdrawal of online support options and chat functions from Fanatec is less than acceptable. For the price we pay for this kit, I don't believe its unreasonable to expect this to work as defined / sold, particularly given the extended delivery times, or at very least have a reasonable method to have the issues resolved in a reasonable timeframe.

    Fanatec - If you cant perform any reasonable level of customer support, you really shouldn't be making the sales.

  • edited July 29

    You wrote on your first post that

    "I am currently running PC driver 334, Wheel base Firmware 640, wheel base motor 22 and Steering wheel 34."


    I think I have red somewhere inside the forum, that Driver 334 and related firmware is not working with the V2 steering wheel.

    Which means you and your friend (if you are both on same drivers) need to update on the latest stable driver for your CSL v1.1.


    EDIT: Don't use the beta 365 cause there are bugs with the universal hub and only 2 buttons are working.

  • edited July 29

    Thanks for your note Alexandros and thanks also for your recommendation.

    I'm new to Fanatec products so have been a little nervous in making changes with Beta drivers in case I break anything. I do have the latest drivers and firmware as available from their website and I did see that update here in the forums but to be honest there are so many abbreviations and acronyms, I wasn't 100% sure if that was worth testing or I would be looking at even more pain. But I will give it a shot.

    I spoke with Fanatec support (very early) this morning and the guy on the phone also suggested the same and pointed me to the download.

    Appreciate your comments.

  • Needless to say the newest downloads didn't work either. There is obviously a bigger issue here, which their IT department has yet to address. Frustrating that even their techs don't have an answer yet.

    I also don't need a driver that'll enable the Formula V2 wheel, yet disable my Universal Hub.


    Truly hope they are working on a solution quickly - I'd like to know how widespread this issue is.

    Open to all suggestions to find a solution.

    Thanks to all the "well versed' sim racers here that have way more knowledge about this stuff than I do.

    Cheers

  • edited July 30



    I think but yet again not sure where to find it that the last safe driver for CSL series was the 346.

    Maybe one of the more knowledgeable users knows more.


    Sorry that can help more mate so you can enjoy your wheel.

  • *** Update *** After a few calls and emails with some very helpful Fanatec support team members and trying a few driver and firmware combinations, including some in Beta, they have opened an RMA and I will be sending the wheel and base back for a change over. Hoping to have better luck on the replacements.

    According to the support technicians, if you have this problem connecting to Xbox with CSL 1.1 base and Formula V2 wheel, it is worth reaching out to them and potentially trying the updates. Anecdotally they appear to be having success on some base / wheel combinations.

    When you do get to talk to someone on the Fanatec technical support team I gotta say they are really nice and as helpful as can be. Fingers crossed the replacement comes quickly and I can get connected.

Sign In or Register to comment.