ClubSport Lenkrad Formula V2 w/ xbox & PS4 bundle??

So I just got duped by the "XBOX READY" icon and bought the CSL Elite bundle (Licensed for PS4) and discovered what a few others have..... NO GO on the xbox.... need a new wheel. So I'm going to sell the ClubSport F1 Esports wheel it came with and buy the ClubSport Lenkrad Formula V2 .

My question... Do we know definitively that the "Officially Licensed for PS4" CSL Elite wheel base & peddles from the bundle will work with the ClubSport Lenkrad Formula V2 on an XBOX?

Or should I just sell the whole bundle and start from scratch (the return process is more of a hassle I'm told).

Go easy on me, this is my first foray into this stuff.


  • Yup, will work just fine.

  • I have the CSL Elite 1.1 (made for Xbox and PC) and the Formula V2 Wheel and I cannot get it to work on Xbox, go into Xbox mode or even be recognized my Xbox. I'm hopeful I'll get it working but mine certainly doesn't 'work just fine'.

  • So I'm in the same boat Nick B is.

    I have the CSL Elite wheelbase, have the Universal Hub (which works just fine, as it should) and literally got the Formula V2 Wheel in the mail an hour ago. Like Nick's Formula V2 wheel, it won't recognize the Xbox, more so it actually locks up the wheelbase. The only way to get it reset, is to pull the power and reboot the wheelbase again.

    IT DOESN'T WORK and is unacceptable.

    For all that want to comment on the fact that the newest driver and or firmware needs to uploaded first - well Nick tried that on his (which he received 3 days earlier) and had an even worse experience. So that idea won't fly. It's as if certain basic "Xbox drivers" (I'm not an IT guy, so I'm sure I'm not using the correct lingo here, but you know what I mean) were not incorporated with his wheel.

    It works with Nick's PC, but not his Xbox. I only have the PC, so the new wheel is basically USELESS to me.

    We tried each other's wheels on our wheelbases with the same results - FAILURE.

    The universal HUB, once again works on both my bas as well as his.

    The fact that NO ONE seems to be AVAILABLE at Fanatec is very disconcerting and frustrating to say the least. Massive delivery delays, and what appears to be a huge quality control problem on their end, but manufacturing has ramped up for demand. They need to be there for their customers to solve issues like these, or people will search elsewhere.

    Right now I am having a very hard time recommending this company, their products or their customer service.


  • I understand the frustration - it does seem like there are a few fanatec people on the forums if that helps.

    I ordered the same wheel last week, And got it today. Shipping / processing time seemed reasonable to me.

    My v2 wheel arrived with the latest firmware on the wheel, so no update was needed or performed.

    I read in the manual about the process to switch modes. I pressed the middle top right button, combined with the bottom left button from the 3 of the bottom center of the wheel that form a triangle.

    I tried this combination while connected to my PC.

    On the tiny screen on my wheel I see it shift from PC, to Comp v2 to Xbox. My base does not support PS4, so it cycled between those 3.

    Note that I did not enter the setup mode first - I just held these buttons.

    I noticed that while in xbox mode, there was a white light on the front of the wheel, bottom center, between those 3 buttons that form a triangle.

    Hopefully this can help - in a perfect world, you would have missed those instructions and tried changing the mode a different way, and trying it this way would fix your issue. But it's entirely possible you got a bum unit.

  • I also have the csl elite wheelbase and the lenkrad formula v2 steering wheel and it is not working on Xbox. I Already updated the firmware via PC to the most Current version and the PC seems to recognize it just fine. But when plugged into the Xbox and switched over to Xbox mode it basically just freezes up and won’t allow you to switch out of that mode or even allow you to turn it off with the power button. I switch it to Xbox mode as jack described and I also see the little white light at the bottom but nothing works. I bought this specifically for Xbox as I don’t have a powerful enough PC to play anything so I’m pretty much out of luck right now unless someone has a solution out there. This is very unacceptable. This thing should pretty much be plug and play for this price.

  • Thx for the suggestions ...

    @ JackFruh.... I will try that and see if it works.

    @ Jay De La O... I agree, it really should be a plug and play. You know there is technology out there to make that happen.


  • Guys, this is a bad fix, but try pulling the USB cable from the xbox after it freezes and connect it back - I thought I saw on a forum somewhere that it fixed an issue people had with a fanatec base on a console - I understand this isn't ideal but, if it works it will at least let you experience the wheel base and decide if you like the construction quality, in game feel etc..

  • @ Jack F

    Are you referring to the "Funky Button" and the "x" (Xbox) buttons from the "triangle?


Sign In or Register to comment.