Need Help! - ClubSport F1 Esports not being detected on CSW v2.0

Hi, really lost here so would appreciate some help.

I have a ClubSport F1 Esports steering wheel which I'm trying to connect to a CSW 2.0.

The CSW 2.0 wheelbase turns on normally, and drivers/firmware seems to install fine.

However, the ClubSport F1 wheel is not seeming to want to be detected - connecting doesn't make it appear in the Fanatec Wheel Properties.

I've tried different drivers and firmwares - all of them do not seem to detect any wheel, except the 282 Wheelbase driver with the 299 firmware but it shows the incorrect ClubSport BMW M3 GT2 wheel (and the FFB and Vibration test does not work)..

Lost for ideas, is there a button to turn on the steering wheel that I'm missing here?

I'm fairly sure I've pushed the steering in to connect properly, and the pins look to be ok..

Thanks

Comments

  • If you are on driver 282 then there you have your problem. This driver is way too old. Please try a newer driver.


    According to the webshop page of the F1 Esports Wheel you need atleast driver 328 with included firmwares.

    I personally suggest you either go with driver 347 or 365 which you can find in the beta driver section:

    https://forum.fanatec.com/categories/beta-drivers

  • edited July 29

    I've tried newer drivers as well (tried 347 and 365; I'm currently on driver 328 with wheelbase firmware v627), and still have the same problem - steering rim doesn't appear in the Fanatec Wheel Properties menu

    When I attach the steering rim, I'm seeing the red light around the 'Start' button of the CSW v2.0 wheelbase flash clock-wise (it's a solid red when the steering rim is not attached).

Sign In or Register to comment.