FanaLab 1.23 beta Download - Post your Feedback here

11516182021

Comments


  • Then I cant help and you need to wait until its properly implemented into FanaLab in a few weeks (hopefully).

    As said, its working for a lot of other people, so there must be some issue on your side but I dont know where,sorry.

  • edited July 8

    I tried one last time and it seems to be a miracle, now it works.

    And contrary to to "Fanatec led" mode, the leds are not synchronised to the ingame leds, like you said.


    Considering I needed an entire day to make them light, how many weeks will I need to make it synchro, considering I can't change the sliders in fanalab?


    edit: I didn't understand how the led thing worked in fanalab, but now I got it.

    I tried with the mercedes it seems to be a good start for those who are interested in having the wheel leds synchronised with ingame leds


  • A little update: it worked in hotlap mode but in carreer (my team carreer) it doesn't work anymore.

  • Yep, MyTeam Mode actually doesnt work with this workaround.

    Maybe that Mode needs UDP format 2020 which is actually not working in FanaLab... So for that mode we need to wait for a new FanaLab version with proper F1 2020 support it seems.

  • I have finished my profiles for all cars in F1 2020 which have LEDs so you dont have to spent the time for yourself to find the correct % values.. ;-)


  • I have tried the suggestions however I seem to have a different issue. when I click enable telemetry I get the following:


  • Did you update the XML file or in game setting properly?

    Your screen shot says it's looking for F1 2019 which I assume you don't have.


    Go to direction C:\users\YOURUSERNAME\AppData\Local\Fanatec\FanaLab\xml (or C:\Users\YOURUSERNAME\AppData\Local\VirtualStore\Program Files (x86)\Fanatec\FanaLab\Control\xml) and open the configuration.xml file.

    Then go to the F1 2019 lines and change the first lines to this:

    <Game majorId="4" minorId="5" isHidden="False" isSupported="True" isFavorite="False">

      <title>F1 2020</title>

      <img>f1_2019.jpg</img>

      <exe>F1_2020.exe</exe>

      <exe>F1_2020_dx12.exe</exe>

      <steamlaunch id="1080110" isSteamInstalled="True">steam://rungameid/1080110</steamlaunch>

    In F1 2020 you need to disable Fanatec LED option, enable UDP-Telemetry, set the UDP-Port to the one you have set in FanaLab, set UDP-Send rate to 60Hz and then set UDP-Format to 2019, NOT 2020!

  • New user question - I see it says I need Beta driver 352 to use this version of fanalab.

    Is 352 pretty stable?

    Does fanalab also work with newer beta drivers?

  • 352 is unstable, better go with 356 or 365 or wait for a even newer much which is supposed to be released rather soon.

    All these drivers however would work with Fanalab 1.23

  • I have exactly the same problem as Viktor.

    I am assuming that not having a copy of 2019 on the PC is a problem even though I have edited the Fanalab Configure.xml file and the 2020 In-Game settings as you have instructed. Having said that I am not able to view the UDP port in Fanalab and assume that it is set when enabling Telemetry, if the error does not appear.

    Would it help if the expected "hardware_settings_config" were to be present where expected? If so do you have a copy of this fie to use as a starting point? or is it simply then going to throw up an error relating to other missing components?

  • Haven't had installed FanaLab until today so far. I use a CSW V2.5 wheelbase, F1 2018 LE Rim and the CSP V3 pedal unit. Due to the fact that this tool is completely new for me, I would like to know, which version works without any issues and is also fully compatible to which driver versions of my equipment.


    As read in this post, it seems that the V1.23 beta makes still some problems and has several issxues.


    looking forward hearing from you and many thanks.

  • I have similar hardware - only difference is my F1 2020 LE wheel. I have V365 drivers and Fanalab 1.23 and I am not aware of any problems. The issue i am not fully grasping in this thread relates to a workaround for the new Codemasters F1 2020 only released a few days ago. But if i can't get that working, pending new Fanalab release, it isn't preventing me from driving F1 2020 without fanalab. Fanalab 1.23 Seems to work with ACC ok.

  • I guess the hardware behind our rims is the same and differs only in the design. I don^t have and I don^t like the gamnes from codemasters itself ;-), so the package of Fanalb 1.23 and the latest beta drivers should make any problems hopefully. Thanks for your immediate reply and kind answer

  • Not sure if this will be of any help, but I found multiple configuration.xml locations on my system. I was only able to get the fix to work after I altered the XML located in: C:\Program Files (x86)\Fanatec\FanaLab\Control\xml

    Keep it flat out 😂


    Win 10 1909/Fanalab V1.23/CSL Elite

  • Thanks. But I'm guessing you have (or had) F1 2019 on your system. Because it's still asking for the My Games / Codemasters config file as per message above

  • when will there be a new FanaLab version that supports Automobilista 2? FanaLab has not been updated for more than half a year.

  • I'm using Fanalab V1 23 and I have no complaints I've had it for about month or so.

    I just installed my GT3 911 Podium wheel and it says to open up the ITM in the Fanalab V1.24 beta inside the folder.

    So do I have to Uninstaller the v1.23 in order to use the Porsche wheel?

  • edited July 10

    Use this software package and instructions to install the button module endurance and Fanalab 1.24, follow them exactly it worked perfectly for me when I did


    https://fanatec.com/media/archive/78/37/e1/Button-Module-Endurance-Software-Package-v1-2.zip

  • Viktor, I don't know if you have resolved this issue yet. If not maybe this will help. I too did not have F1 2019 on my system. So after making the required settings changes in F1 2020, I created the path F1 2019/hardware settings under MyGames. I then placed a copy of the hardware_settings_config.xml file from F1 2020 into F1 2019/hardwaresettings folder. Problem apparently solved. Although I don't know if that means having to copy the file again if I make any changes to other settings.

  • Hi Maurice, I am not familiar with the use of the ,pws files. Is this just a matter of extracting them from the rar into Fanalab/settings/0_1, or is there an import procedure in Fanalab?

  • There is a "Load" Button right beneath the "Save" Button is FanaLab, then you can load the pws into your FanaLab.

    Or just drop them all in once in your C:\users\YOURUSERNAME\AppData\Local\Fanatec\Fanatec\settings\4_5 folder

  • Hi Maurice, many thanks. Still getting to grips with all of this. If i have done this correctly...

    Dumped everything in the 4_5 folder. Presumably I still have to load the pws file for the relevant car (in this case McLaren) which i have done?

    Fanalab is clearly communicating with the game because there is now different activity on the flag lights and I am now getting RPM on the screen on the wheel.

    However, the rev lights on the wheel are lagging behind those on the screen. Whereas without Fanalab, and Fanatec LED to ON, it was fairly accurate. Is that likely to be something I have messed with?

  • Hi , How do we Point the Fanalab Software to find games, Currently it only sees some games from steam , some are thumb nails are greyed out and say unavailable , Some are fine like ACC, F1 2019, AC , Raceroom, Others like AMS2 , and F1 2020 can't be seen at all . I got the 1.23 Version. And all the latest drivers for DD1 and Mclaren Rim etc. Mostly working fine except don't know how to point to new games? Clicking on the game EYE thingy does nothing. Cheers for any help and advice.

  • edited July 11

    Maurice,

    Does Fanalab support the multiple ITM screens on the BME for Assetto Corsa Competizione using 1.24 ?

    I can get the first ITM screen and legacy screens to show up while in Fanalab or ACC but according to the Feature_Support_ITM_reference.pdf that came with the 1.24 software package I should be able to access 5 different screens now when using 1.24.


    I've followed the instructions.txt file exactly that came with the P BME Software Package v1.2 to install everything and it all seems to be working perfectly but I can't seem to figure out how to enable ITM page 2,3,4&5 for Assetto Corsa Competizione. The game is selected, I have created a test profile and it shows up as being loaded in the ITM page at the top but the other ITM pages can't be selected either in Fanalab or on the BME using the tuning button and funky switch.


    PC Driver 356

    WB FW: 670

    SW FW: 9

    PHUB FW: 2

    Fanalab: 1.24

    Any help or info appreciated.


    Cheers

  • AMS2 and F1 2020 are simply not supportes yet because FanaLab 1.23 is 7 months old and these game were released only a few days ago.

  • For now only page 1 is enabled on the BME because of issues on the other pages.

  • Will ETS2 and ATS get some love in next version?

  • edited July 12

    No support is planned at the moment, no.

Sign In or Register to comment.