CSP V3 brake stuttering - completely normal?

Hello guys!

I've just bought my CSP V3 Pedals (2 weeks ago) and out of the box, I couldn't hold a stable value with the brakes, it was flactuating up and under by almost 10% in the games even though I was applying the same pressure. I've tried to fix this with installing the brake performance mod but it still had this behaviour and I think that the sensor is the issue.

I've contacted the support about this and they told me that this was "completely normal" and "This flichering input from the brake is because of the resistance effect caused by the brake Performance kits or the original foam inside the brake cylinder." I am a bit sceptical since it makes accurate braking impossible - the G27 pedals that i had previously were more precise!

I just wanted to ask some of you guys if you are experiencing the same with the brakes or if it's a faulty sensor - thank you in Advance!

Comments

  • Mine did it for about a year. Then it got real bad and the load cell went out. I just ordered 3 load cells so i have a replacement and 2 backups just to be safe. It took a month just to get them to add them to my cart so i could order them.

  • Bone dry elastomers.

  • I've tried lithium grease and also PTFE spray but both didn't change anything, so it's probably related to the load cell that is not working as it should I think

    Just for confirmation - it's not "completely normal" as they told me it is? I hope it's fixable somehow...

Sign In or Register to comment.