McLaren GT3 not recognised random issue

Video here - base starts up, does the normal thing, instead of the readout showing the hardware driver details, it just stays as the 'Fanatec F' and nothing works on the actual wheel, just the steering input from the base. Seemingly random on start up, works fine then maybe the next start up it decides it doesn't want to work. I have to then turn it off, take the wheel off, turn it on, let it turn back and forth, put the wheel back on and hope it works again.

https://www.youtube.com/watch?v=gVU9dA33ZrA

Any ideas?

Many thanks in advance.

Comments

  • I had my share of problems with the McLaren GT3. I hear you are on PC? I updated to the latest beta driver, version 365. The McLaren needs either firmware 25 (driver 311) or firmware 31 (drivr 365) to work without problems.

    What driver do you use?

  • Thanks for the reply. Appreciated.


    Drivers are as follows...


    Wheel Base - 672

    Motor - 22

    Wheel - 31


    So it would seem i have the current driver but still with issues.

  • You have the latest drivers indeed. I have a CSL Elite PS4 base. Maybe that si the difference. I tried a lot of drivers until driver 365 solved a lot of problems for me. I know driver 311 worked also. Do you have another rim? I updated the firmware with the original PS4 rim attaced to my base. After that worked, I updated the firmware on the McLaren rim.

    Contact Fanatec support. I also know some McLaren rims have bad ROM chips.

  • edited July 31

    I've had the stuff for a while - well over a year - just seems to happen every so often, no rhyme or reason.


    I can get going by taking the wheel on and off as I explained, it's just a pain in the arse.


    Typical modern stuff - no logical reason why one day it throws a strop for no apparent reason.


    Thanks for your replies mate.

  • Try to uninstall Fanatec drivers, remove all your USB drivers reboot install Fanatec drivers. Windows might be playing games with you.

  • Thanks Marlon - I think it's more the wheel/base connection/recognition issue.


    It randomly happens when the PC is off as well and the wheel is started independently.


    Take the wheel off, stick it back on again and usually it's fine.

  • I've had this issue with this wheel and the CSW 2.5 since the beginning. It's never worked as it should. I had tapped Fanatec Support about this and they advised the same, update to latest beta driver/firmware package but issue still persists. Given they no longer manufacture this wheel, highly doubtful this will be fixed so as the OP, I have to pull the wheel off and put it back on and it's fine from there on.

Sign In or Register to comment.