CSW V2.5 Does Not Stay Powered On

Hi,

My CSW V2.5 wheel base suddenly turned off. Then, when I went to turn it on again, it does not want to stay on. When I press the power button all I hear are the fans spinning. There is no light around the 'Start' button. When I let go of the power button everything turns off again.

I have tried to hold the power button for 10+ seconds and still the same problem. My PC does not detect it.

The blue LED on the power brick is on.

Please help.

Thank you.

Comments

  • How long have you had it?

  • edited August 4

    I received it on July 29. Got everything setup and was trying it on July 31st. Everything worked amazingly for about 20 minutes before it shutoff :(. Since then I tried turning it on once again, and now nothing happens.

    I contacted support, but it seems like it will take 7+ days for them to respond based on what other people are saying. Add that with having to send it back and for Fanatec to finally send me a new one, I probably won’t have a working base for at least another month. I’m wondering if it would be worth it to just order a new base and refund my defective one? Will Fanatec offer a full refund since it broke within 14 days of receiving it? This way I might get a new base sooner, only being out the money for shipping. 

Sign In or Register to comment.