Formula V2 and DD2 Freezing and wheel now stuck in fw update mode

Since getting the Formula V2 wheel this week I started using it with ACC, RFactor, iRacing with no problems and then from last night I'm getting freezing on the PC in FanaLab and the wheel properties page.

I was on on PC driver 365 before and had no problem and this morning I've tried 346, 352, 356 and I'm back on 365 again now. All have the freezing problem so went back to the latest beta version.

The DD2 is on firmware version 672 and the wheel on v34. I've seen there is a new hex file (RFORMv2_V34_rev187_app.hex) that will most likely solve the freezing problem however I cant get to install it before the wheel properties page freezes or what's happened now is that the fw update page partially uploads the FW to the wheel and then stops and loses connection with the wheel. The upoload stops at random points from 1% up to the most I've had it, 85%; This is the message log from the updater window;

ClubSport Steering Wheel Formula V2 Update Mode

Connected to device successfully!

Collecting device information......

Device information is updated!

Start update progress......

Updating firmware......

IMPORTANT: Please do not power down or disconnect the wheel base during the update process!

Error: Update image failed(No response packet from target device.).

Update process is stopped by error.

This attempt failed at 13%.

Every time the DD2 is powered on now with the wheel connected it automatically goes to firmware update mode with the Firmware Updater screen showing so the wheel is useless now until I can get it to fully run through an fw update.

I'm at a loss of what to try next... anyone have any ideas ?




  • Hi Rob, seems like you might need a support ticket on this one.

    The only advice I'd have for you only works about 5% of the time - Unplug everything, pedals, usb cable from both ends, power cord from DD2, power cord from power supply to the wall.

    Then Plug it all back in.

    When you connect the USB cable to your PC, be sure to connect it direct to the motherboard, not to a usb port on the case, and not through a usb hub. If possible disconnect other usb devices like external sound cards, other joysticks etc.

    See if that helps - to set expectations, it likely will not make a difference, but it's worth trying.

    Oh and here are two more things you could try - create a new user in windows, and then reboot, and log in as that user and see if that makes a difference.

    Lastly, I've not tried this so I don't know if this works - but you could try booting windows in safe mode and try to flash the wheel firmware and see if that makes a difference.

  • Thanks Jack, Ive managed to solve it, by disconnecting al the other USB devices and I I also found a bios update for my X470 motherboard and applied that and I managed to keep a stable connection to the wheel to do the update. everything seems ok now thankfully.



Sign In or Register to comment.