New Load Cell Pedals not working

So as the title states I have a new load cell kit I installed on my CSL Elite pedal set. It is plugged in via USB and it seems it will only recognize the gas pedal. The load Cell brake shows nothing and the now clutch shows a little blip of blue in the brake. What did I do wrong? I have updated to the latest firmware and I tried using Fanalab but it doesn't allow me to tune my pedals. Any help would be appreciated.


  • First thought is to confirm you replaced the control box and connected things to the correct ports.

    2nd thought is to confirm you ran the fanatec control panel app (not fanalab) and calibrate the pedal's min and max while releasing/pressing the pedal.

  • Any updates on that?

    I have the same or simmilar problem: new LC brake kit, replaced the control box, connected everything to the correct ports:

    GAS and CLUTCH are find but LC brake shows nothing and won't react on any input... i tried to install various versions of the drivers, nothings changing.. what to do? send back and hope for working replacement?

  • edited August 2020

    Did you try to update only the pedals by themselves?

    Switch off the wheel base. Disconnect the RJ12, connect via USB to PC, open the the drivers for the pedals only (wheel base still off). Update, check your min/max settings at your preference, disconnect the USB and then connect again with RJ12. Switch on the wheelbase and you should be ready to go.

    If not, check for pinched cables. if cable is sitting correctly inside the ports etc.

    Again if the LC not working correctly, open a support ticket through your account and include a video with the issue (so you can skip some emails going back and forth, which takes time).

  • Did you ever get this fixed? I have the same problem with my clutch and throttle working but no response from my LC brake. Curious what you did to fix it.

Sign In or Register to comment.