DD2 Podium - Wheel Motor Firmware at 0

My DD2 wheel motor firmware will not upgrade and is at 0. Has anyone had this issue before and fixed it? I'm waiting on fanatec support, but hoping to resolve this sooner. I don't know what i'm missing out on being at "0" lol...

Anytime I hit the box to upgrade the software just closes and I have to relaunch.


  • I have the same issue with my DD1

  • So far I've reinstalled several times and tried different version drivers, reformatted my PC and even tried a spare laptop. Still get the same results.

    Awaiting feedback from Fanatec.

  • I heard back from Fanatec yesterday and they suggested I try to uninstall the driver, remove all drivers under the Fanatec container in device manager(with hidden shown), disable all anti-virus & firewalls, reinstall driver v347 and do the firmware and motor updates, but I still get the same issue no matter what I try. Press the update tab, software closes and nothing loads.

    I'm starting to think this may be a larger issue and will need RMA'd. I really hope not, but will wait to hear back from Fanatec on how to proceed next... Keep you guys posted.

  • I'm having the same issue, i,ve tried reinstall after install after reinstall different usb ports so many times now i'm starting to develop a tick or should i say a fanatick (attempt at humour). I will look at the anti virus & firewalls though,looking forward to see what answers you get back.

  • Pretty sure it will need an RMA at this point with all the troubleshooting I've done and Fanatec has made me do. Maybe it can be fixed with a patch, but I've had mine since the Pre-Orders shipped out and still enjoyed using it with "0". I really thought it was my PC, but since the issue has followed to my new one I think it's just faulty. :(

  •  I have initiated a repair-rma for my DD i try everything 😤 but no result .

  • Hopefully fanatec takes care of us quickly and fixes the issue permanently going forward. I've now requested rma, so we will see how long it takes...

  • installed beta 352 then turned on dirt 2.0 the wheel ripped out of my hands and is completely stuck upside down. tried asseto corssa same bad robot. can I go back to not living the pipe dream and when it worked?

  • Had the same issues, you need to update the firmware of the wheelbase. Afterwards update the motor driver.

  • how do you do that?

  • Andy MillerAndy Miller Member
    edited January 2020

    A week later and still no update from Fanatec after replying back that troubleshooting did not work. Very frustrating, especially after having spent the kind of money on their products. DD2 is not cheap for me... I guess I will wait longer...

  • I send mine today for service .Now i have to wait.

  • Hi Robert -

    Hope for speedy return on your base...

  • RMA process has been started by fanatec. Hopefully will have it sent off soon. Adding some pictures below that show the motor at 0. I've tried 3 different computers and multiple drivers, but still unable to upgrade motor firmware past 0.

  • DD2 has been sent out today for RMA. Hoping for speedy return.

  • Andy MillerAndy Miller Member
    edited January 2020

    Thanks Fanatec for getting my DD2 back to me quickly. I didn't receive any shipping information, but luckily it was safe on my porch all day Saturday. It was a nice surprise to find it. :)

  • Mine was lost by DHL 😔now waiting for a new one

Sign In or Register to comment.