Podium Hub doesn't seems to work.

So I have bought a DD1, with a Formula Wheel V2, a Podium hub and a regular drift rim. (Upgraded from Thrustmaster T500rs)

I've installed the DD1 on my RIG, installed the latest drivers (as today), installed the firmware. All that worked fine with the Formula Wheel V2, I've tried it a bunch in Assetto Corsa Competizione and it was amazing.

After that, I've tried to use my drift Rim on the Podium Hub and try it in assetto corsa, so I've bolted the rim on the hub, but when I attach the hub to the wheel base, the podium hub doesn't seem to be detected in the fanatec wheel property page.

This is my fanatec wheel properties with the Formula V2 wheel.

And this is without any wheel (Or with the podium Hub attached)

I'm under the impression that it should detect the podium hub and enable the wheel base (that's the reason why I need the podium hub as I understand it because the wheel base require a controller in the wheel in order to work, so it disable the wheel base if you just have a rim on a standard quick release as I understand it).

I've looked if i was missing drivers or something for the hub itself but on when I download the drivers on the podium hub page it seems like the same drivers as when I installed the DD1 drivers, but less up to date.

Here is my current driver and firmware versions

Am I missing something, is my podium hub defect (I hope not..)


  • So, I managed to make it work (now it's detected in my fanatec wheel page). I don't know what I did to make it work, I swapped wheels a couple of time, then i saw the thing being detected in the fanatec wheel page and as I clicked Ok in the popup message that ask to install firmware, my PC got a blue screen, so I rebooted the PC and the Podium DD1 (it somehow cut the power to the wheelbase with the bluescreen), installed the firmware

    But now, the problem is that when I switch wheel on the DD1 base, the base ask confirmation for the caution warning for the torque key, and as I don't have any button on my rim or any module connected to the podium hub, I cannot confirm, thus I have no FFB whatsoever.

    I've tried without the torque key, I have a little bit of FFB but it's not even enough to feel the front wheel and it's not even close to be viable (I'm actually pretty experienced in drift so I know what it supposed to feel) also it was way better with the T500rs than without the torque key as I tried.

    Is there a trick to this problem? I'm sure I'm not the only fanatec wheel base user that ran into this issue..

  • Something do do with turning the wheel to the left a quarter turn to say yes for torque key.

    should be in the manual.

  • Thanks Ben. Yeah I find it a bit dumb to not include this kind of information in the user manuals. It took a while for me to figure out everything (pretty much all day to install hardware on my rig (pedals and wheel) and install/configure everything software related. But damn it was worth it!

    It's basicly night and day compared to my old T500rs, I knew it would be quite an upgrade, but I'm even impressed (I though the difference wouldn't be that great). Not only the forces are way greater, but all the nuances I can feel way more now (some that i wouldn't even feel at all on non direct wheel drive wheels) and for drifting, I feel like the wheel react way more like it should (especially when throwing the car sideways fast and transitioning fast), with the old wheel i felt bottlenecked by the wheel motor, since it wouldn't make turn the wheel fast enough, I had to throw it in the otherway myself and catch it at the right spot to countersteer fast enough on really fast transitions.. Now it feel much more natural. (Went from a G27 to a T500rs was like a 10 to a 15, but now from T500rs to this it feel like a leap from 15 to 100 XD)

Sign In or Register to comment.